aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anholt2016-01-25 12:16:56 -0600
committerEric Anholt2016-02-03 13:29:52 -0600
commit3c717f61f885240980bfc4273dbd1fc837edc391 (patch)
treedf61d1686c4d466251b059c6c576ee22a50a9439 /Makefile.am
parent0ad32e7ff48e106d654acca79445389651ed6909 (diff)
downloadexternal-libdrm-3c717f61f885240980bfc4273dbd1fc837edc391.tar.gz
external-libdrm-3c717f61f885240980bfc4273dbd1fc837edc391.tar.xz
external-libdrm-3c717f61f885240980bfc4273dbd1fc837edc391.zip
vc4: Add headers and .pc files for VC4 userspace development.
The headers were originally written in Mesa, imported to the kernel, and improved upon in vc4-gpu-tools. These come from the v-g-t copies and will replace the Mesa and v-g-t copies, and hopefully be used from new tests in igt, as well. v2: Fix linking against libdrm_intel instead of libdrm. v3: Drop Libs and Cflags since they'll be inherited from libdrm. v4: Switch to Requires.private. I was wrong about standard practice, apparently only Intel was doing plain Requires (sorry to all involved). Signed-off-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ca415089..feecba72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,6 +29,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
29 --enable-radeon \ 29 --enable-radeon \
30 --enable-amdgpu \ 30 --enable-amdgpu \
31 --enable-nouveau \ 31 --enable-nouveau \
32 --enable-vc4 \
32 --enable-vmwgfx \ 33 --enable-vmwgfx \
33 --enable-omap-experimental-api \ 34 --enable-omap-experimental-api \
34 --enable-exynos-experimental-api \ 35 --enable-exynos-experimental-api \
@@ -79,6 +80,10 @@ if HAVE_TEGRA
79TEGRA_SUBDIR = tegra 80TEGRA_SUBDIR = tegra
80endif 81endif
81 82
83if HAVE_VC4
84VC4_SUBDIR = vc4
85endif
86
82if BUILD_MANPAGES 87if BUILD_MANPAGES
83if HAVE_MANPAGES_STYLESHEET 88if HAVE_MANPAGES_STYLESHEET
84MAN_SUBDIR = man 89MAN_SUBDIR = man
@@ -96,6 +101,7 @@ SUBDIRS = \
96 $(EXYNOS_SUBDIR) \ 101 $(EXYNOS_SUBDIR) \
97 $(FREEDRENO_SUBDIR) \ 102 $(FREEDRENO_SUBDIR) \
98 $(TEGRA_SUBDIR) \ 103 $(TEGRA_SUBDIR) \
104 $(VC4_SUBDIR) \
99 tests \ 105 tests \
100 $(MAN_SUBDIR) 106 $(MAN_SUBDIR)
101 107