aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Deucher2015-04-20 11:04:22 -0500
committerAlex Deucher2015-08-05 12:47:48 -0500
commit09361395363805b5892d48d7bc10cf717e4d2927 (patch)
treec81192a93843d2f9af16df2b9ec71a66579314d5 /configure.ac
parenta3c89dda5b519f6b217bebe97f6795b820931b78 (diff)
downloadexternal-libdrm-09361395363805b5892d48d7bc10cf717e4d2927.tar.gz
external-libdrm-09361395363805b5892d48d7bc10cf717e4d2927.tar.xz
external-libdrm-09361395363805b5892d48d7bc10cf717e4d2927.zip
drm: add libdrm_amdgpu (v7)
This is the new ioctl wrapper used by the new admgpu driver. It's primarily used by xf86-video-amdgpu and mesa. v2: fix amdgpu_drm.h install v3: Integrate some of the sugestions from Emil: clean up Makefile.am, configure.ac capitalize header guards fix _FILE_OFFSET_BITS with config.h use drm_mmap/drm_munmap Remove unused ARRAY_SIZE macro use shared list implementation use shared math implementation use drmGetNodeTypeFromFd helper v4: remove unused tiling defines v5: include amdgpu.h in Makefile.am v6: update amdgpu_drm.h v7: libdrm.h -> libdrm_macros.h Signed-off-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2cf9a190..81ffb2c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,11 @@ AC_ARG_ENABLE(radeon,
86 [Enable support for radeon's KMS API (default: auto)]), 86 [Enable support for radeon's KMS API (default: auto)]),
87 [RADEON=$enableval], [RADEON=auto]) 87 [RADEON=$enableval], [RADEON=auto])
88 88
89AC_ARG_ENABLE(amdgpu,
90 AS_HELP_STRING([--disable-amdgpu],
91 [Enable support for amdgpu's KMS API (default: auto)]),
92 [AMDGPU=$enableval], [AMDGPU=auto])
93
89AC_ARG_ENABLE(nouveau, 94AC_ARG_ENABLE(nouveau,
90 AS_HELP_STRING([--disable-nouveau], 95 AS_HELP_STRING([--disable-nouveau],
91 [Enable support for nouveau's KMS API (default: auto)]), 96 [Enable support for nouveau's KMS API (default: auto)]),
@@ -248,6 +253,9 @@ if test "x$drm_cv_atomic_primitives" = "xnone"; then
248 LIBDRM_ATOMICS_NOT_FOUND_MSG($RADEON, radeon, Radeon, radeon) 253 LIBDRM_ATOMICS_NOT_FOUND_MSG($RADEON, radeon, Radeon, radeon)
249 RADEON=no 254 RADEON=no
250 255
256 LIBDRM_ATOMICS_NOT_FOUND_MSG($AMDGPU, amdgpu, AMD, amdgpu)
257 AMDGPU=no
258
251 LIBDRM_ATOMICS_NOT_FOUND_MSG($NOUVEAU, nouveau, NVIDIA, nouveau) 259 LIBDRM_ATOMICS_NOT_FOUND_MSG($NOUVEAU, nouveau, NVIDIA, nouveau)
252 NOUVEAU=no 260 NOUVEAU=no
253 261
@@ -269,6 +277,9 @@ else
269 if test "x$RADEON" = xauto; then 277 if test "x$RADEON" = xauto; then
270 RADEON=yes 278 RADEON=yes
271 fi 279 fi
280 if test "x$AMDGPU" = xauto; then
281 AMDGPU=yes
282 fi
272 if test "x$NOUVEAU" = xauto; then 283 if test "x$NOUVEAU" = xauto; then
273 NOUVEAU=yes 284 NOUVEAU=yes
274 fi 285 fi
@@ -348,6 +359,11 @@ if test "x$RADEON" = xyes; then
348 AC_DEFINE(HAVE_RADEON, 1, [Have radeon support]) 359 AC_DEFINE(HAVE_RADEON, 1, [Have radeon support])
349fi 360fi
350 361
362AM_CONDITIONAL(HAVE_AMDGPU, [test "x$AMDGPU" = xyes])
363if test "x$AMDGPU" = xyes; then
364 AC_DEFINE(HAVE_AMDGPU, 1, [Have amdgpu support])
365fi
366
351AM_CONDITIONAL(HAVE_TEGRA, [test "x$TEGRA" = xyes]) 367AM_CONDITIONAL(HAVE_TEGRA, [test "x$TEGRA" = xyes])
352if test "x$TEGRA" = xyes; then 368if test "x$TEGRA" = xyes; then
353 AC_DEFINE(HAVE_TEGRA, 1, [Have Tegra support]) 369 AC_DEFINE(HAVE_TEGRA, 1, [Have Tegra support])
@@ -446,6 +462,8 @@ AC_CONFIG_FILES([
446 intel/libdrm_intel.pc 462 intel/libdrm_intel.pc
447 radeon/Makefile 463 radeon/Makefile
448 radeon/libdrm_radeon.pc 464 radeon/libdrm_radeon.pc
465 amdgpu/Makefile
466 amdgpu/libdrm_amdgpu.pc
449 nouveau/Makefile 467 nouveau/Makefile
450 nouveau/libdrm_nouveau.pc 468 nouveau/libdrm_nouveau.pc
451 omap/Makefile 469 omap/Makefile
@@ -477,6 +495,7 @@ echo " libkms $LIBKMS"
477echo " Intel API $INTEL" 495echo " Intel API $INTEL"
478echo " vmwgfx API $VMWGFX" 496echo " vmwgfx API $VMWGFX"
479echo " Radeon API $RADEON" 497echo " Radeon API $RADEON"
498echo " AMDGPU API $AMDGPU"
480echo " Nouveau API $NOUVEAU" 499echo " Nouveau API $NOUVEAU"
481echo " OMAP API $OMAP" 500echo " OMAP API $OMAP"
482echo " EXYNOS API $EXYNOS" 501echo " EXYNOS API $EXYNOS"