aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorInki Dae2012-05-04 05:13:14 -0500
committerRob Clark2012-05-12 10:04:54 -0500
commite07b650662ea0529d99741691c47856ef1034c9c (patch)
tree0f465d978c9316abcc223e3c51c042c7103ea16d /configure.ac
parent86451a12ca52e88a9600ed55f56b8cacd1ac0d6d (diff)
downloadexternal-libdrm-e07b650662ea0529d99741691c47856ef1034c9c.tar.gz
external-libdrm-e07b650662ea0529d99741691c47856ef1034c9c.tar.xz
external-libdrm-e07b650662ea0529d99741691c47856ef1034c9c.zip
libdrm: add exynos drm support
this patch adds libdrm_exynos helper layer that inclues some intefaces for exynos specific gem and virtual display driver and also adds exynos module name to modtest and vbltest. Changelog v2: - fixed exynos broken ioctl. the pointer of uint64_t *edid should be removed. - removed unnecessary definitions. - added drm prime interfaces. this feature is used to share a buffer between drivers or memory managers and for this, please, refer to below links: http://www.mjmwired.net/kernel/Documentation/dma-buf-sharing.txt http://lwn.net/Articles/488664/ this patch is based on a link below: git://anongit.freedesktop.org/mesa/drm commit id: d72a44c7c4f5eea9c1e5bb0c36cb9e0224b9ca22 Reviewed-by: Rob Clark <rob@ti.com> Reviewed-by: Alex Deucher <alexander.deucher@amd.com> Signed-off-by: Inki Dae <inki.dae@samsung.com> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> Signed-off-by: Rob Clark <rob@ti.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 538d0d86..e6e9a9f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,11 @@ AC_ARG_ENABLE(omap-experimental-api,
88 [Enable support for OMAP's experimental API (default: disabled)]), 88 [Enable support for OMAP's experimental API (default: disabled)]),
89 [OMAP=$enableval], [OMAP=no]) 89 [OMAP=$enableval], [OMAP=no])
90 90
91AC_ARG_ENABLE(exynos-experimental-api,
92 AS_HELP_STRING([--enable-exynos-experimental-api],
93 [Enable support for EXYNOS's experimental API (default: disabled)]),
94 [EXYNOS=$enableval], [EXYNOS=no])
95
91dnl =========================================================================== 96dnl ===========================================================================
92dnl check compiler flags 97dnl check compiler flags
93AC_DEFUN([LIBDRM_CC_TRY_FLAG], [ 98AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
@@ -191,6 +196,11 @@ if test "x$OMAP" = xyes; then
191 AC_DEFINE(HAVE_OMAP, 1, [Have OMAP support]) 196 AC_DEFINE(HAVE_OMAP, 1, [Have OMAP support])
192fi 197fi
193 198
199AM_CONDITIONAL(HAVE_EXYNOS, [test "x$EXYNOS" = xyes])
200if test "x$EXYNOS" = xyes; then
201 AC_DEFINE(HAVE_EXYNOS, 1, [Have EXYNOS support])
202fi
203
194PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no]) 204PKG_CHECK_MODULES(CAIRO, cairo, [HAVE_CAIRO=yes], [HAVE_CAIRO=no])
195if test "x$HAVE_CAIRO" = xyes; then 205if test "x$HAVE_CAIRO" = xyes; then
196 AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support]) 206 AC_DEFINE(HAVE_CAIRO, 1, [Have cairo support])
@@ -313,6 +323,8 @@ AC_CONFIG_FILES([
313 nouveau/libdrm_nouveau.pc 323 nouveau/libdrm_nouveau.pc
314 omap/Makefile 324 omap/Makefile
315 omap/libdrm_omap.pc 325 omap/libdrm_omap.pc
326 exynos/Makefile
327 exynos/libdrm_exynos.pc
316 tests/Makefile 328 tests/Makefile
317 tests/modeprint/Makefile 329 tests/modeprint/Makefile
318 tests/modetest/Makefile 330 tests/modetest/Makefile
@@ -333,4 +345,5 @@ echo " vmwgfx API $VMWGFX"
333echo " Radeon API $RADEON" 345echo " Radeon API $RADEON"
334echo " Nouveau API $NOUVEAU" 346echo " Nouveau API $NOUVEAU"
335echo " OMAP API $OMAP" 347echo " OMAP API $OMAP"
348echo " EXYNOS API $EXYNOS"
336echo "" 349echo ""