aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmil Velikov2015-07-15 10:31:15 -0500
committerEmil Velikov2015-07-29 12:04:15 -0500
commitd1f321fdf9367d3a488f81c8c3c8b8aa5b8d69bb (patch)
treeddfff205eda1669e41d24d381741c3f8671131cb /man/Makefile.am
parent1a6efaf68e207302cd9423051b8091fa663bbabe (diff)
downloadexternal-libdrm-d1f321fdf9367d3a488f81c8c3c8b8aa5b8d69bb.tar.gz
external-libdrm-d1f321fdf9367d3a488f81c8c3c8b8aa5b8d69bb.tar.xz
external-libdrm-d1f321fdf9367d3a488f81c8c3c8b8aa5b8d69bb.zip
man: remove .man_fixup workaround
The whole thing is quite messy - the file is used to indicate that the man pages were correctly generated prior to applying the "fixup" (alias) At the same time we use a rule with the same name, to create the same file if the generation has failed. In other words - it attempts to create the file either way. So there is little point in it and we can remove it. Spotted while attempting to build with bmake which kindly blocked on the following (non compliant construct) .man_fixup: | $(miscman_DATA) Cc: Jonathan Gray <jsg@jsg.id.au> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am11
1 files changed, 3 insertions, 8 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 44b63a57..00eb4234 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -37,7 +37,7 @@ MAN_FILES = \
37 $(miscman_aliases_DATA) 37 $(miscman_aliases_DATA)
38 38
39EXTRA_DIST = $(XML_FILES) 39EXTRA_DIST = $(XML_FILES)
40CLEANFILES = $(MAN_FILES) .man_fixup 40CLEANFILES = $(MAN_FILES)
41 41
42XSLTPROC_FLAGS = \ 42XSLTPROC_FLAGS = \
43 --stringparam man.authors.section.enabled 0 \ 43 --stringparam man.authors.section.enabled 0 \
@@ -48,14 +48,9 @@ XSLTPROC_FLAGS = \
48 $(MANPAGES_STYLESHEET) 48 $(MANPAGES_STYLESHEET)
49 49
50XSLTPROC_PROCESS_MAN = \ 50XSLTPROC_PROCESS_MAN = \
51 $(AM_V_GEN)$(XSLTPROC) -o "$@" $(XSLTPROC_FLAGS) "$<" && \ 51 $(AM_V_GEN)$(XSLTPROC) -o "$@" $(XSLTPROC_FLAGS) "$<"
52 touch .man_fixup
53 52
54# Force .man_fixup if $(miscman_DATA) are not built 53$(miscman_aliases_DATA): $(miscman_DATA)
55.man_fixup: | $(miscman_DATA)
56 $(AM_V_GEN)touch .man_fixup
57
58$(miscman_aliases_DATA): $(miscman_DATA) .man_fixup
59 $(AM_V_GEN)if test -n "$@" ; then $(SED) -i -e 's/^\.so \([a-z_]\+\)\.\([0-9]\)$$/\.so man\2\/\1\.\2/' "$@" ; fi 54 $(AM_V_GEN)if test -n "$@" ; then $(SED) -i -e 's/^\.so \([a-z_]\+\)\.\([0-9]\)$$/\.so man\2\/\1\.\2/' "$@" ; fi
60 55
61SUFFIXES = .$(LIB_MAN_SUFFIX) .$(MISC_MAN_SUFFIX) .xml 56SUFFIXES = .$(LIB_MAN_SUFFIX) .$(MISC_MAN_SUFFIX) .xml