aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2018-01-26 09:08:39 -0600
committerEric Engestrom2018-01-29 09:41:52 -0600
commit1d7bbf852094481a8f514ed786b7a7a8af67e5fe (patch)
treee8390c053121a6ccca2991e7c8027e1cfaafbe32 /meson.build
parentd2b0a4ec70d93040159af0cbc15717d35812ffc5 (diff)
downloadexternal-libdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.tar.gz
external-libdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.tar.xz
external-libdrm-1d7bbf852094481a8f514ed786b7a7a8af67e5fe.zip
always define HAVE_VALGRIND
Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 15a1d405..76a081a9 100644
--- a/meson.build
+++ b/meson.build
@@ -257,16 +257,13 @@ foreach t : [[with_intel, 'INTEL'], [with_vmwgfx, 'VMWGFX'],
257 [with_vc4, 'VC4'], 257 [with_vc4, 'VC4'],
258 [with_freedreno_kgsl, 'FREEDRENO_KGSL'], 258 [with_freedreno_kgsl, 'FREEDRENO_KGSL'],
259 [dep_cairo.found(), 'CAIRO'], 259 [dep_cairo.found(), 'CAIRO'],
260 [dep_valgrind.found(), 'VALGRIND'],
260 [with_radeon, 'RADEON']] 261 [with_radeon, 'RADEON']]
261 config.set10('HAVE_@0@'.format(t[1]), t[0]) 262 config.set10('HAVE_@0@'.format(t[1]), t[0])
262endforeach 263endforeach
263if with_freedreno_kgsl and not with_freedreno 264if with_freedreno_kgsl and not with_freedreno
264 error('cannot enable freedreno-kgsl without freedreno support') 265 error('cannot enable freedreno-kgsl without freedreno support')
265endif 266endif
266if dep_valgrind.found()
267 config.set10('HAVE_VALGRIND', true)
268endif
269
270config.set10('_GNU_SOURCE', true) 267config.set10('_GNU_SOURCE', true)
271config_file = configure_file( 268config_file = configure_file(
272 configuration : config, 269 configuration : config,