aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8842201..52c591dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,11 @@ AC_ARG_ENABLE(udev, AS_HELP_STRING([--enable-udev],
43 [Enable support for using udev instead of mknod (default: disabled)]), 43 [Enable support for using udev instead of mknod (default: disabled)]),
44 [UDEV=$enableval], [UDEV=no]) 44 [UDEV=$enableval], [UDEV=no])
45 45
46AC_ARG_ENABLE(libkms,
47 AS_HELP_STRING([--disable-libkms],
48 [Enable KMS mm abstraction library (default: yes)]),
49 [LIBKMS=$enableval], [LIBKMS=yes])
50
46AC_ARG_ENABLE(intel, 51AC_ARG_ENABLE(intel,
47 AS_HELP_STRING([--disable-intel], 52 AS_HELP_STRING([--disable-intel],
48 [Enable support for intel's KMS API (default: auto)]), 53 [Enable support for intel's KMS API (default: auto)]),
@@ -134,6 +139,8 @@ if test "x$UDEV" = xyes; then
134 AC_DEFINE(UDEV, 1, [Have UDEV support]) 139 AC_DEFINE(UDEV, 1, [Have UDEV support])
135fi 140fi
136 141
142AM_CONDITIONAL(HAVE_LIBKMS, [test "x$LIBKMS" = xyes])
143
137AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes]) 144AM_CONDITIONAL(HAVE_NOUVEAU, [test "x$NOUVEAU" = xyes])
138 145
139AM_CONDITIONAL(HAVE_RADEON, [test "x$RADEON" = xyes]) 146AM_CONDITIONAL(HAVE_RADEON, [test "x$RADEON" = xyes])
@@ -199,6 +206,8 @@ AC_SUBST(kernel_source)
199AC_SUBST(WARN_CFLAGS) 206AC_SUBST(WARN_CFLAGS)
200AC_OUTPUT([ 207AC_OUTPUT([
201 Makefile 208 Makefile
209 libkms/Makefile
210 libkms/libkms.pc
202 intel/Makefile 211 intel/Makefile
203 intel/libdrm_intel.pc 212 intel/libdrm_intel.pc
204 radeon/Makefile 213 radeon/Makefile
@@ -215,6 +224,7 @@ AC_OUTPUT([
215echo "" 224echo ""
216echo "$PACKAGE_STRING will be compiled with:" 225echo "$PACKAGE_STRING will be compiled with:"
217echo "" 226echo ""
227echo " libkms $LIBKMS"
218echo " Intel API $INTEL" 228echo " Intel API $INTEL"
219echo " Radeon API $RADEON" 229echo " Radeon API $RADEON"
220echo " Nouveau API $NOUVEAU" 230echo " Nouveau API $NOUVEAU"