aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build86
1 files changed, 86 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 00000000..fdf950b7
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,86 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21inc_tests = include_directories('.')
22
23subdir('util')
24subdir('kms')
25subdir('modeprint')
26subdir('proptest')
27subdir('modetest')
28subdir('vbltest')
29if with_libkms
30 subdir('kmstest')
31endif
32if with_radeon
33 subdir('radeon')
34endif
35if with_amdgpu
36 subdir('amdgpu')
37endif
38if with_exynos
39 subdir('exynos')
40endif
41if with_tegra
42 subdir('tegra')
43endif
44if with_etnaviv
45 subdir('etnaviv')
46endif
47if with_nouveau
48 subdir('nouveau')
49endif
50
51drmsl = executable(
52 'drmsl',
53 files('drmsl.c'),
54 include_directories : [inc_root, inc_drm],
55 link_with : libdrm,
56 c_args : warn_c_args,
57)
58
59hash = executable(
60 'hash',
61 files('hash.c'),
62 include_directories : [inc_root, inc_drm],
63 link_with : libdrm,
64 c_args : warn_c_args,
65)
66
67random = executable(
68 'random',
69 files('random.c'),
70 include_directories : [inc_root, inc_drm],
71 link_with : libdrm,
72 c_args : warn_c_args,
73)
74
75drmdevice = executable(
76 'drmdevice',
77 files('drmdevice.c'),
78 include_directories : [inc_root, inc_drm],
79 link_with : libdrm,
80 c_args : warn_c_args,
81)
82
83test('random', random, timeout : 240)
84test('hash', hash)
85test('drmsl', drmsl)
86test('drmdevice', drmdevice)