aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Herrmann2013-01-16 12:35:25 -0600
committerJesse Barnes2013-01-16 12:59:14 -0600
commit08cb5c1d0245f6bfc1dd4d041eb418bc160c7b05 (patch)
tree7bd42e86debea85d062c19f7db81521f6a6937ca /configure.ac
parent481763c2c7f5224a9f053ab3a2b2356eb89a96f0 (diff)
downloadexternal-libgbm-08cb5c1d0245f6bfc1dd4d041eb418bc160c7b05.tar.gz
external-libgbm-08cb5c1d0245f6bfc1dd4d041eb418bc160c7b05.tar.xz
external-libgbm-08cb5c1d0245f6bfc1dd4d041eb418bc160c7b05.zip
man: fix manpage build instructions
This fixes all the out-of-tree build-failures with manpages and uses a .man_fixup file to avoid overriding man-pages on every build. Manpages are only built if xsltproc is found and the stylesheets are available locally. You can disable building manpages with --disable-manpages so the quite expensive xsltproc procedure can be skipped. Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 10cc9a42..9ee79409 100644
--- a/configure.ac
+++ b/configure.ac
@@ -226,8 +226,26 @@ if test "x$HAVE_LIBUDEV" = xyes; then
226fi 226fi
227AM_CONDITIONAL(HAVE_LIBUDEV, [test "x$HAVE_LIBUDEV" = xyes]) 227AM_CONDITIONAL(HAVE_LIBUDEV, [test "x$HAVE_LIBUDEV" = xyes])
228 228
229# xsltproc for docbook manpages
230AC_ARG_ENABLE([manpages],
231 AS_HELP_STRING([--disable-manpages], [disable manpages @<:@default=enabled@:>@]),
232 [MANS=$enableval], [MANS=auto])
229AC_PATH_PROG(XSLTPROC, xsltproc) 233AC_PATH_PROG(XSLTPROC, xsltproc)
230AM_CONDITIONAL([HAVE_XSLTPROC], [test "x$XSLTPROC" != "x"]) 234AM_CONDITIONAL([BUILD_MANPAGES], [test "x$XSLTPROC" != "x" -a "x$MANS" != "xno"])
235
236# check for offline man-pages stylesheet
237AC_MSG_CHECKING([for docbook manpages stylesheet])
238MANPAGES_STYLESHEET="http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl"
239AC_PATH_PROGS_FEATURE_CHECK([XSLTPROC_TMP], [xsltproc],
240 AS_IF([`"$ac_path_XSLTPROC_TMP" --nonet "$MANPAGES_STYLESHEET" > /dev/null 2>&1`],
241 [HAVE_MANPAGES_STYLESHEET=yes]))
242if test "x$HAVE_MANPAGES_STYLESHEET" = "xyes"; then
243 AC_SUBST(MANPAGES_STYLESHEET)
244 AC_MSG_RESULT([yes])
245else
246 AC_MSG_RESULT([no])
247fi
248AM_CONDITIONAL([HAVE_MANPAGES_STYLESHEET], [test "x$HAVE_MANPAGES_STYLESHEET" = "xyes"])
231 249
232if test "x$INTEL" != "xno" -o "x$RADEON" != "xno" -o "x$NOUVEAU" != "xno" -o "x$OMAP" != "xno"; then 250if test "x$INTEL" != "xno" -o "x$RADEON" != "xno" -o "x$NOUVEAU" != "xno" -o "x$OMAP" != "xno"; then
233 # Check for atomic intrinsics 251 # Check for atomic intrinsics