aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Wilson2012-02-12 18:19:17 -0600
committerChris Wilson2012-02-12 18:24:14 -0600
commitced219ebbd3b266ac8326223bad62f994907ae6b (patch)
treee0e983205c69428a69e84d2a0c1bf5df2106785b /configure.ac
parent90b23cc24c19fbe131d84237c55311cafeb4ca21 (diff)
downloadexternal-libgbm-ced219ebbd3b266ac8326223bad62f994907ae6b.tar.gz
external-libgbm-ced219ebbd3b266ac8326223bad62f994907ae6b.tar.xz
external-libgbm-ced219ebbd3b266ac8326223bad62f994907ae6b.zip
configure: Fix pkg-config test in absence of valgrind
The empty string used for the not case is replaced by the default if-else clause and so causes the configure to fail in the absence of valgrind. Which is not quite what was intended. Instead use the common idiom of setting a variable depending on whether the true or false branch is taken and emit the conditional code as a second step. Reported-by: Tobias Jakobi <liquid.acid@gmx.net> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d72874bc..97bbcb72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,8 +261,10 @@ if test "x$INTEL" != "xno" -o "x$RADEON" != "xno"; then
261 fi 261 fi
262fi 262fi
263 263
264PKG_CHECK_MODULES(VALGRIND, [valgrind], 264PKG_CHECK_MODULES(VALGRIND, [valgrind], [have_valgrind=yes], [have_valgrind=no])
265 AC_DEFINE([HAVE_VALGRIND], 1, [Use valgrind intrinsics to suppress false warings]),) 265if test "x$have_valgrind" = "xyes"; then
266 AC_DEFINE([HAVE_VALGRIND], 1, [Use valgrind intrinsics to suppress false warnings])
267fi
266 268
267AM_CONDITIONAL(HAVE_INTEL, [test "x$INTEL" != "xno"]) 269AM_CONDITIONAL(HAVE_INTEL, [test "x$INTEL" != "xno"])
268AM_CONDITIONAL(HAVE_RADEON, [test "x$RADEON" != "xno"]) 270AM_CONDITIONAL(HAVE_RADEON, [test "x$RADEON" != "xno"])