aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Wilson2009-10-03 17:17:57 -0500
committerChris Wilson2009-10-03 17:18:19 -0500
commitac34f599eabcfc414d4d3300063988d4749813f4 (patch)
treee720f5edb9d5e9ccf52c54a47e3259f68b867804 /tests/Makefile.am
parentab3300c5816ee26e2d74ac99e2d84c3dfd7cdf82 (diff)
downloadexternal-libgbm-ac34f599eabcfc414d4d3300063988d4749813f4.tar.gz
external-libgbm-ac34f599eabcfc414d4d3300063988d4749813f4.tar.xz
external-libgbm-ac34f599eabcfc414d4d3300063988d4749813f4.zip
tests: Disable intel-specific tests with --disable-intel
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 98c106b3..af44d6a3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,5 @@
1NULL:=#
2
1AM_CPPFLAGS = \ 3AM_CPPFLAGS = \
2 -I $(top_srcdir)/shared-core \ 4 -I $(top_srcdir)/shared-core \
3 -I $(top_srcdir)/libdrm 5 -I $(top_srcdir)/libdrm
@@ -8,9 +10,10 @@ noinst_PROGRAMS = \
8 dristat \ 10 dristat \
9 drmstat 11 drmstat
10 12
11SUBDIRS = \ 13SUBDIRS =
12 modeprint \ 14
13 modetest 15if HAVE_INTEL
16endif
14 17
15if HAVE_LIBUDEV 18if HAVE_LIBUDEV
16 19
@@ -37,14 +40,24 @@ TESTS = \
37 getstats \ 40 getstats \
38 setversion \ 41 setversion \
39 updatedraw \ 42 updatedraw \
43 $(NULL)
44
45if HAVE_INTEL
46SUBDIRS += \
47 modeprint \
48 modetest \
49 $(NULL)
50
51TESTS += \
40 gem_basic \ 52 gem_basic \
41 gem_flink \ 53 gem_flink \
42 gem_readwrite \ 54 gem_readwrite \
43 gem_mmap 55 gem_mmap \
56 $(NULL)
57endif
44 58
45EXTRA_PROGRAMS = $(TESTS) 59EXTRA_PROGRAMS = $(TESTS)
46 60
47endif 61endif
48 62
49CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES) 63CLEANFILES = $(EXTRA_PROGRAMS) $(EXTRA_LTLIBRARIES)
50