aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Baker2017-09-13 13:46:13 -0500
committerDylan Baker2018-01-12 11:40:48 -0600
commit5f7deb50787b82038cc35fb1e31b761e33e5a341 (patch)
tree6a9fe255f2c5a8b0ab556118fb0cd3dd9de17634 /tests/amdgpu/meson.build
parentf115de819bc10bb36565f344a66fa619219911b9 (diff)
downloadexternal-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.tar.gz
external-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.tar.xz
external-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.zip
Add meson build system
This patch adds a complete meson build system, including tests and install. It has the necessary hooks to allow it be used as a subproject for other meson based builds such as mesa. Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-and-tested-by: Igor Gnatenko <i.gnatenko.brain@gmail.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'tests/amdgpu/meson.build')
-rw-r--r--tests/amdgpu/meson.build34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/amdgpu/meson.build b/tests/amdgpu/meson.build
new file mode 100644
index 00000000..4c1237c6
--- /dev/null
+++ b/tests/amdgpu/meson.build
@@ -0,0 +1,34 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21if dep_cunit.found()
22 amdgpu_test = executable(
23 'amdgpu_test',
24 files(
25 'amdgpu_test.c', 'basic_tests.c', 'bo_tests.c', 'cs_tests.c',
26 'vce_tests.c', 'uvd_enc_tests.c', 'vcn_tests.c', 'deadlock_tests.c',
27 'vm_tests.c',
28 ),
29 dependencies : [dep_cunit, dep_threads],
30 include_directories : [inc_root, inc_drm, include_directories('../../amdgpu')],
31 link_with : [libdrm, libdrm_amdgpu],
32 install : with_install_tests,
33 )
34endif