aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorInki Dae2013-02-18 06:51:00 -0600
committerRob Clark2013-03-08 10:49:42 -0600
commitbbf6e3dea3c79ea8e0c3e1dd8f80014201e003fc (patch)
treeccf81397767c8ee57073fb6e1e4fef45a1acb766 /tests/exynos/Makefile.am
parentade2ad2d66ac341a12eca37bcb30d40199eb4e02 (diff)
downloadexternal-libgbm-bbf6e3dea3c79ea8e0c3e1dd8f80014201e003fc.tar.gz
external-libgbm-bbf6e3dea3c79ea8e0c3e1dd8f80014201e003fc.tar.xz
external-libgbm-bbf6e3dea3c79ea8e0c3e1dd8f80014201e003fc.zip
libdrm/exynos: add test application for 2d gpu.
This patch adds library and test application for g2d gpu(fimg2d). The fimg2d hardware is a 2D graphics accelerator(G2D) that supports Bit Block Transfer(BitBLT). The library includes the following primitive drawing operations: .solid fill - This operation fills the given buffer with the given color data. .copy - This operation copies contents in source buffer to destination buffer. .copy_with_scale - This operation copies contents in source buffer to destination buffer scaling up or down properly. .blend - This operation blends contents in source buffer with the ones in destination buffer. And the above operations uses gem handle or user space address allocated by malloc() as source or destination buffer. And the test application includes just simple primitive drawing tests with the above library. And the guide to test is as the following, "#exynos_fimg2d_test -s connector_id@crtc_id:mode" With this above simple command, four primitive drawing operations would be called step by step and also rendered on the output device to the given connector and crtc id. Signed-off-by: Inki Dae <inki.dae@samsung.com> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> Signed-off-by: Rob Clark <robdclark@gmail.com>
Diffstat (limited to 'tests/exynos/Makefile.am')
-rw-r--r--tests/exynos/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/exynos/Makefile.am b/tests/exynos/Makefile.am
new file mode 100644
index 00000000..bf9ad820
--- /dev/null
+++ b/tests/exynos/Makefile.am
@@ -0,0 +1,19 @@
1AM_CFLAGS = \
2 -I $(top_srcdir)/include/drm \
3 -I $(top_srcdir)/libkms/ \
4 -I $(top_srcdir)/exynos \
5 -I $(top_srcdir)
6
7noinst_PROGRAMS = \
8 exynos_fimg2d_test
9
10exynos_fimg2d_test_LDADD = \
11 $(top_builddir)/libdrm.la \
12 $(top_builddir)/libkms/libkms.la \
13 $(top_builddir)/exynos/libdrm_exynos.la
14
15exynos_fimg2d_test_SOURCES = \
16 exynos_fimg2d_test.c
17
18run: exynos_fimg2d_test
19 ./exynos_fimg2d_test