aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Baker2017-09-13 13:46:13 -0500
committerDylan Baker2018-01-12 11:40:48 -0600
commit5f7deb50787b82038cc35fb1e31b761e33e5a341 (patch)
tree6a9fe255f2c5a8b0ab556118fb0cd3dd9de17634 /tests/proptest/meson.build
parentf115de819bc10bb36565f344a66fa619219911b9 (diff)
downloadexternal-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.tar.gz
external-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.tar.xz
external-libgbm-5f7deb50787b82038cc35fb1e31b761e33e5a341.zip
Add meson build system
This patch adds a complete meson build system, including tests and install. It has the necessary hooks to allow it be used as a subproject for other meson based builds such as mesa. Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-and-tested-by: Igor Gnatenko <i.gnatenko.brain@gmail.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'tests/proptest/meson.build')
-rw-r--r--tests/proptest/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/proptest/meson.build b/tests/proptest/meson.build
new file mode 100644
index 00000000..22d7473e
--- /dev/null
+++ b/tests/proptest/meson.build
@@ -0,0 +1,28 @@
1# Copyright © 2017 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21proptest = executable(
22 'proptest',
23 files('proptest.c'),
24 c_args : warn_c_args,
25 include_directories : [inc_root, inc_tests, inc_drm],
26 link_with : [libdrm, libutil],
27 install : with_install_tests,
28)