aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..740ea6eb
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
1lib_LTLIBRARIES = libgbm.la
2
3libgbm_la_SOURCES = \
4 gbm.c \
5 backend.c \
6 common.c
7
8libgbm_la_LIBADD = \
9 @UDEV_LIBS@
10
11libgbm_la_CFLAGS = \
12 @UDEV_CFLAGS@ \
13 -D_OS_UNIX=1 \
14 -DMODULEDIR='"$(exec_prefix)/lib/gbm"'
15
16extdir = $(includedir)/gbm
17ext_HEADERS = \
18 gbm.h \
19 gbmint.h \
20 common_drm.h
21
22pkgconfigdir = $(libdir)/pkgconfig
23pkgconfig_DATA = gbm.pc