aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 0 insertions, 42 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 5cfb210c..00000000
--- a/configure.ac
+++ /dev/null
@@ -1,42 +0,0 @@
1#
2# Copyright 2005 Red Hat, Inc.
3#
4# Permission to use, copy, modify, distribute, and sell this software and its
5# documentation for any purpose is hereby granted without fee, provided that
6# the above copyright notice appear in all copies and that both that
7# copyright notice and this permission notice appear in supporting
8# documentation, and that the name of Red Hat not be used in
9# advertising or publicity pertaining to distribution of the software without
10# specific, written prior permission. Red Hat makes no
11# representations about the suitability of this software for any purpose. It
12# is provided "as is" without express or implied warranty.
13#
14# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
15# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
16# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
17# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
18# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
19# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
20# PERFORMANCE OF THIS SOFTWARE.
21#
22
23# Initialize Autoconf
24AC_PREREQ([2.60])
25AC_INIT([libgbm], [2.0.0],
26 [https://bugs.freedesktop.org/enter_bug.cgi?product=wayland], [libgbm])
27AC_CONFIG_SRCDIR([Makefile.am])
28AC_CONFIG_HEADERS([config.h])
29
30# Initialize Automake
31AM_INIT_AUTOMAKE([foreign dist-bzip2])
32AM_MAINTAINER_MODE
33
34# Initialize libtool
35AC_PROG_LIBTOOL
36
37# Obtain compiler/linker options for dependencies
38PKG_CHECK_MODULES([LIBUDEV], [libudev])
39PKG_CHECK_MODULES([DRM], [libdrm])
40
41AC_CONFIG_FILES([Makefile gbm.pc])
42AC_OUTPUT