aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'exynos/meson.build')
-rw-r--r--exynos/meson.build54
1 files changed, 54 insertions, 0 deletions
diff --git a/exynos/meson.build b/exynos/meson.build
new file mode 100644
index 00000000..30d36405
--- /dev/null
+++ b/exynos/meson.build
@@ -0,0 +1,54 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21libdrm_exynos = shared_library(
22 'drm_exynos',
23 [files('exynos_drm.c', 'exynos_fimg2d.c'), config_file],
24 c_args : warn_c_args,
25 include_directories : [inc_root, inc_drm],
26 link_with : libdrm,
27 dependencies : [dep_pthread_stubs],
28 version : '1.0.0',
29 install : true,
30)
31
32install_headers('exynos_drmif.h', subdir : 'libdrm')
33install_headers('exynos_drm.h', 'exynos_fimg2d.h', subdir : 'exynos')
34
35ext_libdrm_exynos = declare_dependency(
36 link_with : [libdrm, libdrm_exynos],
37 include_directories : [inc_drm, include_directories('.')],
38)
39
40pkg.generate(
41 name : 'libdrm_exynos',
42 libraries : libdrm_exynos,
43 subdirs : ['.', 'libdrm', 'exynos'],
44 version : '0.7',
45 requires_private : 'libdrm',
46 description : 'Userspace interface to exynos kernel DRM services',
47)
48
49test(
50 'exynos-symbol-check',
51 prog_bash,
52 env : env_test,
53 args : [files('exynos-symbol-check'), libdrm_exynos]
54)