aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'radeon/meson.build')
-rw-r--r--radeon/meson.build63
1 files changed, 63 insertions, 0 deletions
diff --git a/radeon/meson.build b/radeon/meson.build
new file mode 100644
index 00000000..b02166fe
--- /dev/null
+++ b/radeon/meson.build
@@ -0,0 +1,63 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21
22libdrm_radeon = shared_library(
23 'drm_radeon',
24 [
25 files(
26 'radeon_bo_gem.c', 'radeon_cs_gem.c', 'radeon_cs_space.c', 'radeon_bo.c',
27 'radeon_cs.c', 'radeon_surface.c',
28 ),
29 config_file,
30 ],
31 c_args : warn_c_args,
32 include_directories : [inc_root, inc_drm],
33 link_with : libdrm,
34 dependencies : [dep_pthread_stubs],
35 version : '1.0.1',
36 install : true,
37)
38
39ext_libdrm_radeon = declare_dependency(
40 link_with : [libdrm, libdrm_radeon],
41 include_directories : [inc_drm, include_directories('.')],
42)
43
44install_headers(
45 'radeon_bo.h', 'radeon_cs.h', 'radeon_surface.h', 'radeon_bo_gem.h',
46 'radeon_cs_gem.h', 'radeon_bo_int.h', 'radeon_cs_int.h', 'r600_pci_ids.h',
47 subdir : 'libdrm'
48)
49
50pkg.generate(
51 name : 'libdrm_radeon',
52 libraries : libdrm_radeon,
53 subdirs : ['.', 'libdrm'],
54 version : meson.project_version(),
55 requires_private : 'libdrm',
56 description : 'Userspace interface to kernel DRM services for radeon',
57)
58
59test(
60 'radeon-symbol-check',
61 prog_bash,
62 args : [files('radeon-symbol-check'), libdrm_radeon]
63)