aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'tegra/meson.build')
-rw-r--r--tegra/meson.build53
1 files changed, 53 insertions, 0 deletions
diff --git a/tegra/meson.build b/tegra/meson.build
new file mode 100644
index 00000000..1f5c74b3
--- /dev/null
+++ b/tegra/meson.build
@@ -0,0 +1,53 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21libdrm_tegra = shared_library(
22 'drm_tegra',
23 [files('tegra.c'), config_file],
24 include_directories : [inc_root, inc_drm],
25 link_with : libdrm,
26 dependencies : [dep_pthread_stubs, dep_atomic_ops],
27 c_args : warn_c_args,
28 version : '0.0.0',
29 install : true,
30)
31
32ext_libdrm_tegra = declare_dependency(
33 link_with : [libdrm, libdrm_tegra],
34 include_directories : [inc_drm, include_directories('.')],
35)
36
37install_headers('tegra.h', subdir : 'libdrm')
38
39pkg.generate(
40 name : 'libdrm_tegra',
41 libraries : libdrm_tegra,
42 subdirs : ['.', 'libdrm'],
43 version : meson.project_version(),
44 requires_private : 'libdrm',
45 description : 'Userspace interface to Tegra kernel DRM services',
46)
47
48test(
49 'tegra-symbol-check',
50 prog_bash,
51 env : env_test,
52 args : [files('tegra-symbol-check'), libdrm_tegra]
53)