aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to 'tests/kms/meson.build')
-rw-r--r--tests/kms/meson.build49
1 files changed, 49 insertions, 0 deletions
diff --git a/tests/kms/meson.build b/tests/kms/meson.build
new file mode 100644
index 00000000..1f7f724d
--- /dev/null
+++ b/tests/kms/meson.build
@@ -0,0 +1,49 @@
1# Copyright © 2017-2018 Intel Corporation
2
3# Permission is hereby granted, free of charge, to any person obtaining a copy
4# of this software and associated documentation files (the "Software"), to deal
5# in the Software without restriction, including without limitation the rights
6# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
7# copies of the Software, and to permit persons to whom the Software is
8# furnished to do so, subject to the following conditions:
9
10# The above copyright notice and this permission notice shall be included in
11# all copies or substantial portions of the Software.
12
13# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
14# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
15# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
16# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
17# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
18# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
19# SOFTWARE.
20
21
22libkms_test = static_library(
23 'kms-test',
24 files(
25 'libkms-test-crtc.c', 'libkms-test-device.c', 'libkms-test-framebuffer.c',
26 'libkms-test-plane.c', 'libkms-test-screen.c',
27 ),
28 include_directories : [inc_root, inc_tests, inc_drm],
29 link_with : libdrm,
30 c_args : warn_c_args,
31)
32
33kms_steal_crtc = executable(
34 'kms-steal-crtc',
35 files('kms-steal-crtc.c'),
36 dependencies : dep_cairo,
37 include_directories : [inc_root, inc_tests, inc_drm],
38 link_with : [libkms_test, libutil],
39 install : with_install_tests,
40)
41
42kms_universal_planes = executable(
43 'kms-universal-planes',
44 files('kms-universal-planes.c'),
45 dependencies : dep_cairo,
46 include_directories : [inc_root, inc_tests, inc_drm],
47 link_with : [libkms_test],
48 install : with_install_tests,
49)