diff options
Diffstat (limited to 'tests/modetest/meson.build')
-rw-r--r-- | tests/modetest/meson.build | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/modetest/meson.build b/tests/modetest/meson.build new file mode 100644 index 00000000..2a081845 --- /dev/null +++ b/tests/modetest/meson.build | |||
@@ -0,0 +1,29 @@ | |||
1 | # Copyright © 2018 Intel Corporation | ||
2 | |||
3 | # Permission is hereby granted, free of charge, to any person obtaining a copy | ||
4 | # of this software and associated documentation files (the "Software"), to deal | ||
5 | # in the Software without restriction, including without limitation the rights | ||
6 | # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
7 | # copies of the Software, and to permit persons to whom the Software is | ||
8 | # furnished to do so, subject to the following conditions: | ||
9 | |||
10 | # The above copyright notice and this permission notice shall be included in | ||
11 | # all copies or substantial portions of the Software. | ||
12 | |||
13 | # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
14 | # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
15 | # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
16 | # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
17 | # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
18 | # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE | ||
19 | # SOFTWARE. | ||
20 | |||
21 | modetest = executable( | ||
22 | 'modetest', | ||
23 | files('buffers.c', 'cursor.c', 'modetest.c'), | ||
24 | c_args : [warn_c_args, '-Wno-pointer-arith'], | ||
25 | include_directories : [inc_root, inc_tests, inc_drm], | ||
26 | dependencies : [dep_threads, dep_cairo], | ||
27 | link_with : [libdrm, libutil], | ||
28 | install : with_install_tests, | ||
29 | ) | ||