aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomi Valkeinen2016-05-22 13:51:52 -0500
committerTomi Valkeinen2016-05-23 01:43:27 -0500
commit17b890d342473d4ff0559dc35eea56f5c9ae1ae0 (patch)
tree373d2de74f1dde05fc3dce88be40195265773150 /CMakeLists.txt
parentebfe02d5cd4e04d0df471669190e4feb1e2e493c (diff)
downloadexternal-libkmsxx-17b890d342473d4ff0559dc35eea56f5c9ae1ae0.tar.gz
external-libkmsxx-17b890d342473d4ff0559dc35eea56f5c9ae1ae0.tar.xz
external-libkmsxx-17b890d342473d4ff0559dc35eea56f5c9ae1ae0.zip
improve build type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbb2ceb..1308650 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,10 +2,10 @@ cmake_minimum_required(VERSION 2.8)
2project(kms++) 2project(kms++)
3 3
4IF(NOT CMAKE_BUILD_TYPE) 4IF(NOT CMAKE_BUILD_TYPE)
5 SET(CMAKE_BUILD_TYPE Release CACHE STRING 5 message(STATUS "Setting build type to 'Release' as none was specified.")
6 "Choose the type of build, options are: Debug, Release." 6 SET(CMAKE_BUILD_TYPE Release CACHE STRING "Choose the type of build." FORCE)
7 FORCE) 7 set_property(CACHE CMAKE_BUILD_TYPE PROPERTY STRINGS "Debug" "Release" "MinSizeRel" "RelWithDebInfo")
8ENDIF(NOT CMAKE_BUILD_TYPE) 8ENDIF()
9 9
10set(LIBKMS_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers") 10set(LIBKMS_ENABLE_PYTHON ON CACHE BOOL "Enable Python wrappers")
11set(LIBKMS_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube") 11set(LIBKMS_ENABLE_KMSCUBE OFF CACHE BOOL "Enable kmscube")