aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSathishkumar2013-07-30 00:50:14 -0500
committerSaurabh Bipin Chandra2013-08-27 16:12:42 -0500
commitf71e00630af23f1dd7d2a0df87d9b5b524c823a8 (patch)
tree956d57896e212423862da2031aabaa50ba2d7f01 /Makefile.am
parent17668bcb5a1f7f9db2ba225b1825bc55365c3e66 (diff)
downloadhardware-ti-libdce-f71e00630af23f1dd7d2a0df87d9b5b524c823a8.tar.gz
hardware-ti-libdce-f71e00630af23f1dd7d2a0df87d9b5b524c823a8.tar.xz
hardware-ti-libdce-f71e00630af23f1dd7d2a0df87d9b5b524c823a8.zip
[GLP] Libdce linux implementation
make install & libdce.c issue fix 1. make install has been fixed. libdce.h will be installed in /usr/include, libdce.so files in /usr/lib and libdce.pc in /usr/lib/pkgconfig on using --prefix=/usr. By default the prefix is /usr/local. 2. init and deinit calls are removed from libdce.h 3. dce_set_fd and dce_get_fd calls are implemented in libdce.c 4. configure.ac checks for libmmrpc and makefile.am modified to link with libmmrpc. configure.ac and makefile.am modified 1. Codec_engine,xdctolls,framework_components,ipc,xdctools and xdaias paths needs to be exported. Configure.ac checks for the exported paths. 2. Makefile.am is modified to have the exported paths in the include directories list for the compiler. Modifications done after review 1. Comments added in memplugin_linux.c. White spaces removed manually and cleaned up libdce.c, memplugin.h. dce_priv.h is modified to have File and line number in the logs. linux/dce.h file is removed. Libdce modifications for linux Linux Specific libdce functionality added. 1. memplugin calls specific to linux are added in memplugin_linux.c 2. Error and debug logs implementation for linux in dce_priv.h 3. xll and wayland specific files are moved to linux folder Change-Id: Ib41e6a52d902376cdabbb939dee7585944720d92 Signed-off-by: Saurabh Bipin Chandra <a0131926@ti.com> Signed-off-by: Sathishkumar <x0203598@ti.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..93d14d4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,34 @@
1## Process this file with automake to produce Makefile.in
2
3
4lib_LTLIBRARIES = libdce.la
5
6
7CE_CFLAGS = \
8 -I$(CODEC_ENGINE)/ \
9 -I$(FRAMEWORK_COMPONENTS) \
10 -I$(IVAHD_CODECS) \
11 -I$(XDAIAS) \
12 -I$(XDCTOOLS)/ \
13 -I$(IPC)/packages/ti/ipc/mm \
14 -DBUILDOS_LINUX=1 \
15 -Wno-pointer-to-int-cast
16
17
18libdce_la_SOURCES = libdce.c memplugin_linux.c
19libdce_la_CFLAGS = $(WARN_CFLAGS) $(CE_CFLAGS) $(DRM_CFLAGS) $(X11_CFLAGS) $(WAYLAND_CFLAGS)
20libdce_la_LDFLAGS = -no-undefined -version-info 1:0:0
21libdce_la_LIBADD = $(DRM_LIBS) $(X11_LIBS) $(WAYLAND_LIBS) $(MMRPC_LIBS)
22
23if ENABLE_X11
24libdce_la_SOURCES += linux/libdce-x11.c
25endif
26if ENABLE_WAYLAND
27libdce_la_SOURCES += linux/libdce-wayland.c linux/wayland-drm-protocol.c
28endif
29
30libdce_la_includedir = $(includedir)
31libdce_la_include_HEADERS = libdce.h
32
33pkgconfig_DATA = libdce.pc
34pkgconfigdir = $(libdir)/pkgconfig