aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini2018-11-15 06:25:00 -0600
committerTom Rini2018-11-15 06:25:00 -0600
commitf6206f8587fc7ec82a57dbbeb5de0f94b3c2ef49 (patch)
tree446838afad8fa40690b63298e4b92c35dd2a5d27
parent6f443330186676004148930b4dd77f1c2735bd36 (diff)
downloadu-boot-f6206f8587fc7ec82a57dbbeb5de0f94b3c2ef49.tar.gz
u-boot-f6206f8587fc7ec82a57dbbeb5de0f94b3c2ef49.tar.xz
u-boot-f6206f8587fc7ec82a57dbbeb5de0f94b3c2ef49.zip
travis: Ensure we use pytest 2.8.7
The latest version of pytest (4.0.0) makes some of the code we have in test/py/conftest.py a fatal error that needs to be migrated. Unfortunately this in turn requires changes that don't exist in older versions of pytest such as 2.8.7 that ships with Ubuntu 16.04. Force travis to use this older version of pytest. Signed-off-by: Tom Rini <trini@konsulko.com>
-rw-r--r--.travis.yml2
1 files changed, 1 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 6ce2ef7fba..a061f02399 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -47,7 +47,7 @@ install:
47 - cat ~/.buildman 47 - cat ~/.buildman
48 - virtualenv /tmp/venv 48 - virtualenv /tmp/venv
49 - . /tmp/venv/bin/activate 49 - . /tmp/venv/bin/activate
50 - pip install pytest 50 - pip install pytest==2.8.7
51 - pip install python-subunit 51 - pip install python-subunit
52 - grub-mkimage -o ~/grub_x86.efi -O i386-efi normal echo lsefimmap lsefi lsefisystab efinet tftp minicmd 52 - grub-mkimage -o ~/grub_x86.efi -O i386-efi normal echo lsefimmap lsefi lsefisystab efinet tftp minicmd
53 - grub-mkimage -o ~/grub_x64.efi -O x86_64-efi normal echo lsefimmap lsefi lsefisystab efinet tftp minicmd 53 - grub-mkimage -o ~/grub_x64.efi -O x86_64-efi normal echo lsefimmap lsefi lsefisystab efinet tftp minicmd