aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Vander Stichele2002-12-08 08:50:10 -0600
committerThomas Vander Stichele2002-12-08 08:50:10 -0600
commit708cf898e85bb1742870f6b3cabcc74b28f01c5f (patch)
tree022549fcd528cd742ef2fc6569ebd94a0030e97f /configure.ac
parent2a19514098f24c47f8642e7f0b4b762e5dc9d05d (diff)
downloadgst-plugins-bad0-10-708cf898e85bb1742870f6b3cabcc74b28f01c5f.tar.gz
gst-plugins-bad0-10-708cf898e85bb1742870f6b3cabcc74b28f01c5f.tar.xz
gst-plugins-bad0-10-708cf898e85bb1742870f6b3cabcc74b28f01c5f.zip
parallel install fixes
Original commit message from CVS: parallel install fixes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6e9958ede..cf981eb89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,17 @@ dnl when going to/from release please set the nano (fourth number) right !
14dnl releases only do Wall, cvs and prerelease does Werror too 14dnl releases only do Wall, cvs and prerelease does Werror too
15AS_VERSION(gst-plugins, GST_PLUGINS_VERSION, 0, 4, 2, 1, GST_ERROR="-Wall", GST_ERROR="-Wall -Werror") 15AS_VERSION(gst-plugins, GST_PLUGINS_VERSION, 0, 4, 2, 1, GST_ERROR="-Wall", GST_ERROR="-Wall -Werror")
16AM_INIT_AUTOMAKE($PACKAGE,$VERSION) 16AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
17AS_LIBTOOL(GST_PLUGINS, 0, 0, 0, yes) 17
18dnl our libraries and install dirs use major.minor as a version
19GST_MAJORMINOR=$GST_PLUGINS_VERSION_MAJOR.$GST_PLUGINS_VERSION_MINOR
20AC_SUBST(GST_MAJORMINOR)
21
22dnl CURRENT, REVISION, AGE
23dnl - library source changed -> increment REVISION
24dnl - interfaces added/removed/changed -> increment CURRENT, REVISION = 0
25dnl - interfaces added -> increment AGE
26dnl - interfaces removed -> AGE = 0
27AS_LIBTOOL(GST_PLUGINS, 1, 0, 0)
18 28
19dnl FIXME take something else ? 29dnl FIXME take something else ?
20AC_CONFIG_SRCDIR([gst/law/alaw.c]) 30AC_CONFIG_SRCDIR([gst/law/alaw.c])
@@ -136,19 +146,23 @@ GST_CHECK_FEATURE(GCONF, [GConf libraries], , [
136]) 146])
137 147
138dnl check for gstreamer; uninstalled is selected preferentially -- see pkg-config(1) 148dnl check for gstreamer; uninstalled is selected preferentially -- see pkg-config(1)
139PKG_CHECK_MODULES(GST, gstreamer >= $GST_PLUGINS_VERSION_MAJOR.$GST_PLUGINS_VERSION_MINOR.$GST_PLUGINS_VERSION_MICRO, 149PKG_CHECK_MODULES(GST, gstreamer-$GST_MAJORMINOR >= $GST_PLUGINS_VERSION_MAJOR.$GST_PLUGINS_VERSION_MINOR.$GST_PLUGINS_VERSION_MICRO,
140 HAVE_GST="yes", HAVE_GST="no") 150 HAVE_GST="yes", HAVE_GST="no")
141 151
142if test "x$HAVE_GST" = "xno"; then 152if test "x$HAVE_GST" = "xno"; then
143 AC_MSG_ERROR(no GStreamer found) 153 AC_MSG_ERROR(no GStreamer found)
144fi 154fi
145 155
146GST_TOOLS_DIR=`pkg-config --variable=toolsdir gstreamer` 156GST_TOOLS_DIR=`pkg-config --variable=toolsdir gstreamer-$GST_MAJORMINOR`
147if test -z $GST_TOOLS_DIR; then 157if test -z $GST_TOOLS_DIR; then
148 AC_MSG_ERROR([no tools dir defined in GStreamer pkg-config file; core upgrade needed.]) 158 AC_MSG_ERROR([no tools dir defined in GStreamer pkg-config file; core upgrade needed.])
149fi 159fi
150AC_SUBST(GST_TOOLS_DIR) 160AC_SUBST(GST_TOOLS_DIR)
151 161
162dnl additional gstcontrol libs
163GST_CONTROL_LIBS=`pkg-config --variable=gstcontrol_libs gstreamer-$GST_MAJORMINOR`
164AC_SUBST(GST_CONTROL_LIBS)
165
152dnl Set up conditionals for (target) architecture: 166dnl Set up conditionals for (target) architecture:
153dnl ============================================== 167dnl ==============================================
154 168