aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Schleef2010-05-19 19:12:55 -0500
committerDavid Schleef2010-05-19 20:24:02 -0500
commitc3d497776187243ffe96d36f7632817dfaf7e852 (patch)
treef9f15fec844c37ab66338ca45779c348f7c58fe1 /configure.ac
parente3925075f95e7afcf6b1787df618da70f1460494 (diff)
downloadgst-plugins-bad0-10-c3d497776187243ffe96d36f7632817dfaf7e852.tar.gz
gst-plugins-bad0-10-c3d497776187243ffe96d36f7632817dfaf7e852.tar.xz
gst-plugins-bad0-10-c3d497776187243ffe96d36f7632817dfaf7e852.zip
Split out GST_PLUGINS_BAD_CFLAGS from GST_CFLAGS
Move include directives for gst-libs into GST_PLUGINS_BAD_CFLAGS, and fix all the Makefiles that use it. This is so that all the include directories are added in the proper order: first the directories in srcdir/builddir, then gst-plugins-base dirs, then gstreamer dirs. If the order is wrong, installed headers may be used instead of local headers and/or uninstalled headers from -base.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 552980736..d03c40d74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1587,11 +1587,15 @@ dnl FIXME: do we want to rename to GST_ALL_* ?
1587dnl prefer internal headers to already installed ones 1587dnl prefer internal headers to already installed ones
1588dnl also add builddir include for enumtypes and marshal 1588dnl also add builddir include for enumtypes and marshal
1589dnl add GST_OPTION_CFLAGS, but overridable 1589dnl add GST_OPTION_CFLAGS, but overridable
1590GST_CXXFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS \$(GST_OPTION_CXXFLAGS)" 1590GST_CXXFLAGS="$GST_CFLAGS \$(GST_OPTION_CXXFLAGS)"
1591GST_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS \$(GST_OPTION_CFLAGS)" 1591GST_CFLAGS="$GST_CFLAGS \$(GST_OPTION_CFLAGS)"
1592AC_SUBST(GST_CFLAGS) 1592AC_SUBST(GST_CFLAGS)
1593AC_SUBST(GST_CXXFLAGS) 1593AC_SUBST(GST_CXXFLAGS)
1594AC_SUBST(GST_LIBS) 1594AC_SUBST(GST_LIBS)
1595GST_PLUGINS_BAD_CXXFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs"
1596GST_PLUGINS_BAD_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs"
1597AC_SUBST(GST_PLUGINS_BAD_CFLAGS)
1598AC_SUBST(GST_PLUGINS_BAD_CXXFLAGS)
1595 1599
1596dnl LDFLAGS really should only contain flags, not libs - they get added before 1600dnl LDFLAGS really should only contain flags, not libs - they get added before
1597dnl whatevertarget_LIBS and -L flags here affect the rest of the linking 1601dnl whatevertarget_LIBS and -L flags here affect the rest of the linking