aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr2013-05-06 16:28:27 -0500
committerDenys Dmytriyenko2013-05-07 10:56:54 -0500
commitd981052c34af3a8e2f20651a010062fa7e1e0964 (patch)
tree4ee78dd74c89672e93c8110fa20301f252263a74
parent3375807c9f79062685512b44790961e9537ef9fa (diff)
downloadmeta-arago-glsdk-d981052c34af3a8e2f20651a010062fa7e1e0964.tar.gz
meta-arago-glsdk-d981052c34af3a8e2f20651a010062fa7e1e0964.tar.xz
meta-arago-glsdk-d981052c34af3a8e2f20651a010062fa7e1e0964.zip
av-examples: Grab CFLAGS from OE or Rules.make
* When building from OE CFLAGS will be passed in. * When building from within the sdk CFLAGS from Rules.make will be used. * This insures the optimal CFLAGS are used which corrects optimization and * also the correct toolchain settings (ie softfp/hardfp) are used. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--meta-arago-extras/recipes-multimedia/av-examples/av-examples_1.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-arago-extras/recipes-multimedia/av-examples/av-examples_1.0.bb b/meta-arago-extras/recipes-multimedia/av-examples/av-examples_1.0.bb
index 3782cba..dec17a8 100644
--- a/meta-arago-extras/recipes-multimedia/av-examples/av-examples_1.0.bb
+++ b/meta-arago-extras/recipes-multimedia/av-examples/av-examples_1.0.bb
@@ -12,7 +12,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
12COMPATIBLE_MACHINE = "(omap3)" 12COMPATIBLE_MACHINE = "(omap3)"
13 13
14BRANCH ?= "master" 14BRANCH ?= "master"
15SRCREV = "ac75d09d29a805d89c49dd2741b79f3069e97827" 15SRCREV = "87469a47bf91d681f15f0a2eb368fe695b21508c"
16 16
17SRC_URI = "git://gitorious.org/av_examples/av_examples.git;protocol=git;branch=${BRANCH}" 17SRC_URI = "git://gitorious.org/av_examples/av_examples.git;protocol=git;branch=${BRANCH}"
18 18
@@ -24,6 +24,7 @@ INSANE_SKIP_${PN} = "True"
24do_compile() { 24do_compile() {
25 touch debug 25 touch debug
26 export CROSS_COMPILE=${TARGET_PREFIX} 26 export CROSS_COMPILE=${TARGET_PREFIX}
27 export CFLAGS='${TARGET_CC_ARCH}'
27 make release LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" PLATFORM="${MACHINE}" 28 make release LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" PLATFORM="${MACHINE}"
28} 29}
29 30