aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk/defconfig1
-rw-r--r--recipes-kernel/linux/linux-ti-glsdk_3.8.bb31
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-ti-glsdk/defconfig b/recipes-kernel/linux/linux-ti-glsdk/defconfig
new file mode 100644
index 0000000..926b35a
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-glsdk/defconfig
@@ -0,0 +1 @@
use-kernel-config=omap2plus_defconfig
diff --git a/recipes-kernel/linux/linux-ti-glsdk_3.8.bb b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
new file mode 100644
index 0000000..2746188
--- /dev/null
+++ b/recipes-kernel/linux/linux-ti-glsdk_3.8.bb
@@ -0,0 +1,31 @@
1SECTION = "kernel"
2DESCRIPTION = "Linux kernel for TI devices supported by the GLSDK product"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5KERNEL_IMAGETYPE = "uImage"
6
7inherit kernel
8
9require recipes-kernel/linux/linux-dtb.inc
10require recipes-kernel/linux/setup-defconfig.inc
11
12KERNEL_DEVICETREE_omap5-evm = "arch/arm/boot/dts/omap5-sevm.dts arch/arm/boot/dts/omap5-uevm.dts"
13KERNEL_DEVICETREE_dra7xx-evm = "arch/arm/boot/dts/dra7-evm.dts"
14
15COMPATIBLE_MACHINE = "omap-a15"
16
17DEFAULT_PREFERENCE = "-1"
18
19S = "${WORKDIR}/git"
20
21BRANCH = "master"
22
23SRCREV = "4e8193eb3b7465d7f67cd8c7e6c2ed99dad1a483"
24PV = "3.8.13"
25
26# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
27MACHINE_KERNEL_PR_append = "a+gitr${SRCPV}"
28
29SRC_URI = "git://git.ti.com/ti-linux-kernel/ti-linux-3-8-y-kernel.git;protocol=git;branch=${BRANCH} \
30 file://defconfig \
31 "