diff options
author | Devarsh Thakkar | 2022-05-24 05:30:30 -0500 |
---|---|---|
committer | Devarsh Thakkar | 2022-05-24 07:58:25 -0500 |
commit | 0d1b740906f182f6570f9d01b52ad92dab1aae88 (patch) | |
tree | 28339631d1e864e356608e7e3ebb24be4f586ea9 | |
parent | 555353694313767b596361eb4ad50bde07602b42 (diff) | |
download | meta-processor-sdk-0d1b740906f182f6570f9d01b52ad92dab1aae88.tar.gz meta-processor-sdk-0d1b740906f182f6570f9d01b52ad92dab1aae88.tar.xz meta-processor-sdk-0d1b740906f182f6570f9d01b52ad92dab1aae88.zip |
recipes-bsp: u-boot: Revert UHS mode enable
Instabilities were observed on few SD cards when UHS speed modes were
enabled. Therefore, disable UHS modes and voltage switching by removing
the repective nodes in the device tree.
Signed-off-by: Devarsh Thakkar <devarsht@ti.com>
3 files changed, 211 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging/0001-Revert-arm-dts-k3-am625-sk-u-boot-Add-u-boot-tag-to-.patch b/recipes-bsp/u-boot/u-boot-ti-staging/0001-Revert-arm-dts-k3-am625-sk-u-boot-Add-u-boot-tag-to-.patch new file mode 100644 index 0000000..6bba9a7 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-ti-staging/0001-Revert-arm-dts-k3-am625-sk-u-boot-Add-u-boot-tag-to-.patch | |||
@@ -0,0 +1,85 @@ | |||
1 | From d3bfcc889ca1f59798f25db94e4d56b4105ce268 Mon Sep 17 00:00:00 2001 | ||
2 | From: Aswath Govindraju <a-govindraju@ti.com> | ||
3 | Date: Tue, 24 May 2022 10:58:06 +0530 | ||
4 | Subject: [tiU21.01 PATCH v2 1/2] Revert "arm: dts: k3-am625-sk-u-boot: Add | ||
5 | u-boot tag to dt nodes for enabling UHS speed modes in SPL" | ||
6 | |||
7 | This reverts commit 22247f725fd7b8ebc49738db64feefa4edb0ae99. | ||
8 | |||
9 | Instabilities were observed on few SD cards when UHS speed modes were | ||
10 | enabled. Therefore, disable UHS modes and voltage switching by removing the | ||
11 | repective nodes in the device tree. | ||
12 | |||
13 | Signed-off-by: Aswath Govindraju <a-govindraju@ti.com> | ||
14 | --- | ||
15 | arch/arm/dts/k3-am625-sk-u-boot.dtsi | 40 ---------------------------- | ||
16 | 1 file changed, 40 deletions(-) | ||
17 | |||
18 | diff --git a/arch/arm/dts/k3-am625-sk-u-boot.dtsi b/arch/arm/dts/k3-am625-sk-u-boot.dtsi | ||
19 | index 16562cf4942b..f2ad332f9f5d 100644 | ||
20 | --- a/arch/arm/dts/k3-am625-sk-u-boot.dtsi | ||
21 | +++ b/arch/arm/dts/k3-am625-sk-u-boot.dtsi | ||
22 | @@ -92,10 +92,6 @@ | ||
23 | u-boot,dm-spl; | ||
24 | }; | ||
25 | |||
26 | -&main_gpio0 { | ||
27 | - u-boot,dm-spl; | ||
28 | -}; | ||
29 | - | ||
30 | &main_i2c0 { | ||
31 | u-boot,dm-spl; | ||
32 | }; | ||
33 | @@ -104,18 +100,6 @@ | ||
34 | u-boot,dm-spl; | ||
35 | }; | ||
36 | |||
37 | -&main_i2c1 { | ||
38 | - u-boot,dm-spl; | ||
39 | -}; | ||
40 | - | ||
41 | -&main_i2c1_pins_default { | ||
42 | - u-boot,dm-spl; | ||
43 | -}; | ||
44 | - | ||
45 | -&exp1 { | ||
46 | - u-boot,dm-spl; | ||
47 | -}; | ||
48 | - | ||
49 | &sdhci0 { | ||
50 | u-boot,dm-spl; | ||
51 | }; | ||
52 | @@ -225,30 +209,6 @@ | ||
53 | u-boot,dm-spl; | ||
54 | }; | ||
55 | |||
56 | -&vmain_pd { | ||
57 | - u-boot,dm-spl; | ||
58 | -}; | ||
59 | - | ||
60 | -&vcc_5v0 { | ||
61 | - u-boot,dm-spl; | ||
62 | -}; | ||
63 | - | ||
64 | -&vcc_3v3_sys { | ||
65 | - u-boot,dm-spl; | ||
66 | -}; | ||
67 | - | ||
68 | -&vdd_mmc1 { | ||
69 | - u-boot,dm-spl; | ||
70 | -}; | ||
71 | - | ||
72 | -&vdd_sd_dv { | ||
73 | - u-boot,dm-spl; | ||
74 | -}; | ||
75 | - | ||
76 | -&vdd_sd_dv_pins_default { | ||
77 | - u-boot,dm-spl; | ||
78 | -}; | ||
79 | - | ||
80 | &dmsc { | ||
81 | u-boot,dm-spl; | ||
82 | k3_sysreset: sysreset-controller { | ||
83 | -- | ||
84 | 2.17.1 | ||
85 | |||
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging/0002-Revert-configs-am62x_evm_a53_defconfig-Enable-config.patch b/recipes-bsp/u-boot/u-boot-ti-staging/0002-Revert-configs-am62x_evm_a53_defconfig-Enable-config.patch new file mode 100644 index 0000000..933fa40 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-ti-staging/0002-Revert-configs-am62x_evm_a53_defconfig-Enable-config.patch | |||
@@ -0,0 +1,114 @@ | |||
1 | From df868e6bbfb4f589ab52944eaf0fd02c8d1a2f35 Mon Sep 17 00:00:00 2001 | ||
2 | From: Aswath Govindraju <a-govindraju@ti.com> | ||
3 | Date: Tue, 24 May 2022 11:04:02 +0530 | ||
4 | Subject: [tiU21.01 PATCH v2 2/2] Revert "configs: am62x_evm_a53_defconfig: | ||
5 | Enable configs required to add support for UHS modes" | ||
6 | |||
7 | This reverts commit 70c33dd821811a05c595f29ecac5abae23534768. | ||
8 | |||
9 | Instabilities were observed on few SD cards when UHS speed modes were | ||
10 | enabled. Therefore, disable UHS modes and votlage switching by removing | ||
11 | their respective configs. | ||
12 | |||
13 | Signed-off-by: Aswath Govindraju <a-govindraju@ti.com> | ||
14 | --- | ||
15 | configs/am62x_evm_a53_defconfig | 22 ++-------------------- | ||
16 | 1 file changed, 2 insertions(+), 20 deletions(-) | ||
17 | |||
18 | diff --git a/configs/am62x_evm_a53_defconfig b/configs/am62x_evm_a53_defconfig | ||
19 | index e3a25a3cb90a..15127e4cb058 100644 | ||
20 | --- a/configs/am62x_evm_a53_defconfig | ||
21 | +++ b/configs/am62x_evm_a53_defconfig | ||
22 | @@ -1,6 +1,5 @@ | ||
23 | CONFIG_ARM=y | ||
24 | CONFIG_ARCH_K3=y | ||
25 | -CONFIG_SPL_GPIO_SUPPORT=y | ||
26 | CONFIG_SPL_LIBCOMMON_SUPPORT=y | ||
27 | CONFIG_SPL_LIBGENERIC_SUPPORT=y | ||
28 | CONFIG_SYS_MALLOC_F_LEN=0x8000 | ||
29 | @@ -11,7 +10,6 @@ CONFIG_TARGET_AM625_A53_EVM=y | ||
30 | CONFIG_ENV_SIZE=0x20000 | ||
31 | CONFIG_ENV_OFFSET=0x680000 | ||
32 | CONFIG_SYS_SPI_U_BOOT_OFFS=0x280000 | ||
33 | -CONFIG_DM_GPIO=y | ||
34 | CONFIG_SPL_DM_SPI=y | ||
35 | CONFIG_SPL_TEXT_BASE=0x80080000 | ||
36 | CONFIG_SPL_MMC_SUPPORT=y | ||
37 | @@ -30,7 +28,6 @@ CONFIG_SPL_LOAD_FIT_ADDRESS=0x81000000 | ||
38 | CONFIG_BOARD_LATE_INIT=y | ||
39 | CONFIG_MISC_INIT_R=y | ||
40 | CONFIG_SPL_BOARD_INIT=y | ||
41 | -CONFIG_SPL_BOARD_INIT=y | ||
42 | CONFIG_AVB_VERIFY=y | ||
43 | CONFIG_ANDROID_AB=y | ||
44 | CONFIG_SPL_SYS_MALLOC_SIMPLE=y | ||
45 | @@ -46,7 +43,6 @@ CONFIG_SPL_DM_MAILBOX=y | ||
46 | CONFIG_SPL_DM_SPI_FLASH=y | ||
47 | CONFIG_SPL_NET_SUPPORT=y | ||
48 | CONFIG_SPL_NET_VCI_STRING="AM62X U-Boot A53 SPL" | ||
49 | -CONFIG_SPL_POWER_SUPPORT=y | ||
50 | CONFIG_SPL_POWER_DOMAIN=y | ||
51 | CONFIG_SPL_RAM_SUPPORT=y | ||
52 | CONFIG_SPL_RAM_DEVICE=y | ||
53 | @@ -54,8 +50,6 @@ CONFIG_SPL_RAM_DEVICE=y | ||
54 | CONFIG_SPL_SPI_FLASH_SFDP_SUPPORT=y | ||
55 | CONFIG_SPL_SPI_LOAD=y | ||
56 | CONFIG_SPL_THERMAL=y | ||
57 | -CONFIG_SPL_USB_GADGET=y | ||
58 | -CONFIG_SPL_DFU=y | ||
59 | CONFIG_SPL_YMODEM_SUPPORT=y | ||
60 | CONFIG_CMD_ADTIMG=y | ||
61 | CONFIG_CMD_ABOOTIMG=y | ||
62 | @@ -89,6 +83,7 @@ CONFIG_SPL_OF_TRANSLATE=y | ||
63 | CONFIG_CLK=y | ||
64 | CONFIG_SPL_CLK=y | ||
65 | CONFIG_CLK_TI_SCI=y | ||
66 | +CONFIG_SPL_DFU=y | ||
67 | CONFIG_DFU_MMC=y | ||
68 | CONFIG_DFU_RAM=y | ||
69 | CONFIG_DFU_SF=y | ||
70 | @@ -103,20 +98,12 @@ CONFIG_FASTBOOT_FLASH=y | ||
71 | CONFIG_FASTBOOT_FLASH_MMC_DEV=0 | ||
72 | CONFIG_FASTBOOT_CMD_OEM_FORMAT=y | ||
73 | CONFIG_TI_SCI_PROTOCOL=y | ||
74 | -CONFIG_DA8XX_GPIO=y | ||
75 | -CONFIG_DM_PCA953X=y | ||
76 | -CONFIG_SPL_DM_PCA953X=y | ||
77 | CONFIG_DM_I2C=y | ||
78 | -CONFIG_DM_I2C_GPIO=y | ||
79 | CONFIG_SYS_I2C_OMAP24XX=y | ||
80 | CONFIG_DM_MAILBOX=y | ||
81 | CONFIG_K3_SEC_PROXY=y | ||
82 | CONFIG_DM_MMC=y | ||
83 | CONFIG_SUPPORT_EMMC_BOOT=y | ||
84 | -CONFIG_MMC_IO_VOLTAGE=y | ||
85 | -CONFIG_SPL_MMC_IO_VOLTAGE=y | ||
86 | -CONFIG_MMC_UHS_SUPPORT=y | ||
87 | -CONFIG_SPL_MMC_UHS_SUPPORT=y | ||
88 | CONFIG_MMC_HS200_SUPPORT=y | ||
89 | CONFIG_SPL_MMC_HS200_SUPPORT=y | ||
90 | CONFIG_MMC_SDHCI=y | ||
91 | @@ -140,12 +127,6 @@ CONFIG_SPL_PINCTRL=y | ||
92 | CONFIG_PINCTRL_SINGLE=y | ||
93 | CONFIG_POWER_DOMAIN=y | ||
94 | CONFIG_TI_SCI_POWER_DOMAIN=y | ||
95 | -CONFIG_DM_REGULATOR=y | ||
96 | -CONFIG_SPL_DM_REGULATOR=y | ||
97 | -CONFIG_DM_REGULATOR_FIXED=y | ||
98 | -CONFIG_SPL_DM_REGULATOR_FIXED=y | ||
99 | -CONFIG_DM_REGULATOR_GPIO=y | ||
100 | -CONFIG_SPL_DM_REGULATOR_GPIO=y | ||
101 | CONFIG_K3_SYSTEM_CONTROLLER=y | ||
102 | CONFIG_REMOTEPROC_TI_K3_ARM64=y | ||
103 | CONFIG_DM_RESET=y | ||
104 | @@ -171,6 +152,7 @@ CONFIG_USB_DWC3=y | ||
105 | CONFIG_USB_DWC3_GENERIC=y | ||
106 | CONFIG_USB_DWC3_AM62=y | ||
107 | CONFIG_USB_GADGET=y | ||
108 | +CONFIG_SPL_USB_GADGET=y | ||
109 | CONFIG_USB_GADGET_MANUFACTURER="Texas Instruments" | ||
110 | CONFIG_USB_GADGET_VENDOR_NUM=0x0451 | ||
111 | CONFIG_USB_GADGET_PRODUCT_NUM=0x6165 | ||
112 | -- | ||
113 | 2.17.1 | ||
114 | |||
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend new file mode 100644 index 0000000..4a590af --- /dev/null +++ b/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend | |||
@@ -0,0 +1,12 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI_append_am62xx-evm = " \ | ||
4 | file://0001-Revert-arm-dts-k3-am625-sk-u-boot-Add-u-boot-tag-to-.patch \ | ||
5 | file://0002-Revert-configs-am62x_evm_a53_defconfig-Enable-config.patch \ | ||
6 | " | ||
7 | |||
8 | SRC_URI_append_am62xx-evm-k3r5 = " \ | ||
9 | file://0001-Revert-arm-dts-k3-am625-sk-u-boot-Add-u-boot-tag-to-.patch \ | ||
10 | file://0002-Revert-configs-am62x_evm_a53_defconfig-Enable-config.patch \ | ||
11 | " | ||
12 | PR = "r28" | ||