card: fix has_atomic if libdrm does not have atomic support