]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gst-plugin-ducati.git/blobdiff - src/Makefile.am
Revert "ducati: fix build when encoders are missing"
[glsdk/gst-plugin-ducati.git] / src / Makefile.am
index 2e702077604a433521014fb19e2dcbb87bb11c16..ecb68b3827d2de952148f16f9f789639b417ae0b 100644 (file)
@@ -13,7 +13,7 @@ noinst_HEADERS = \
        gstducatih264enc.h \
        gstducatimpeg4enc.h \
        gstducatividenc.h \
-       gstducatibufferpool.h \
+       gstducatibufferpriv.h \
        gstducati.h
 
 # sources used to compile this plug-in
@@ -26,15 +26,31 @@ libgstducati_la_SOURCES = \
        gstducatimpeg4dec.c \
        gstducatih264dec.c \
        gstducatividdec.c \
-       gstducatibufferpool.c \
        gstducatih264enc.c \
        gstducatimpeg4enc.c \
        gstducatividenc.c \
+       gstducatibufferpriv.c \
        gstducati.c \
        $(noinst_HEADERS)
 
 # compiler and linker flags used to compile this plugin, set in configure.ac
-libgstducati_la_CFLAGS = $(GST_CFLAGS) $(MEMMGR_CFLAGS) $(LIBDCE_CFLAGS) -DGST_USE_UNSTABLE_API
-libgstducati_la_LIBADD = $(GST_LIBS) $(MEMMGR_LIBS) $(LIBDCE_LIBS) -lgstvideo-0.10 -lgstbasevideo-0.10
-libgstducati_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_ALL_LDFLAGS) --no-undefined
+libgstducati_la_CFLAGS = \
+       $(GST_CFLAGS) \
+       $(LIBDCE_CFLAGS) \
+       -DGST_USE_UNSTABLE_API
+
+libgstducati_la_LIBADD = \
+       $(GST_LIBS) \
+       $(LIBDCE_LIBS) \
+       -lgstdmabuf-0.10 \
+       -lgstdrm-0.10 \
+       -lgstvideo-0.10 \
+       -lgstbasevideo-0.10
+
+libgstducati_la_LDFLAGS = \
+       $(GST_PLUGIN_LDFLAGS) \
+       $(GST_ALL_LDFLAGS) \
+       --no-undefined
+
 libgstducati_la_LIBTOOLFLAGS = --tag=disable-static
+