]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - libs/gst/Makefile.am
DEBIAN: Debianization
[glsdk/gstreamer0-10.git] / libs / gst / Makefile.am
index 3bd8a76a39a262f0512384d8481d1d65b4772630..65a4499da70bc4d99d6e022905bc29ad45c94f46 100644 (file)
@@ -1,3 +1,36 @@
-SUBDIRS = control getbits bytestream
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
 
-DIST_SUBDIRS = control getbits bytestream
+if GST_DISABLE_NET
+SUBDIRS_NET =
+else
+if HAVE_SYS_SOCKET_H
+SUBDIRS_NET = net
+else
+if HAVE_WINSOCK2_H
+SUBDIRS_NET = net
+else
+SUBDIRS_NET =
+endif
+endif
+endif
+
+if GST_DISABLE_REGISTRY
+SUBDIRS_HELPERS =
+else
+SUBDIRS_HELPERS = helpers
+endif
+
+SUBDIRS_ALWAYS = base controller dataprotocol
+
+SUBDIRS = $(SUBDIRS_ALWAYS) $(SUBDIRS_CHECK) $(SUBDIRS_NET) $(SUBDIRS_HELPERS)
+DIST_SUBDIRS = $(SUBDIRS_ALWAYS) check net helpers
+
+Android.mk: Makefile.am
+       echo $(PWD)
+       androgenizer -:PROJECT gstreamer \
+        -:SUBDIR $(patsubst %, libs/gst/%, $(SUBDIRS)) \
+       > $@