]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - tests/Makefile.am
g_thread_create() is deprecated in GLib master, use g_thread_try_new() instead
[glsdk/gstreamer0-10.git] / tests / Makefile.am
index 019363d923b6de01d3a30b377b6cc0bc326e2ab3..23ff192b73664da5639843777eef4e7f9899dd58 100644 (file)
@@ -1,8 +1,35 @@
-noinst_PROGRAMS = init loadall simplefake states caps queue registry paranoia rip mp3encode autoplug props
+EXTRA_DIST = README
 
-LDADD = $(GLIB_LIBS) $(GTK_LIBS) $(top_builddir)/gst/libgst.la
-CFLAGS = -Wall
+if BUILD_TESTS
+## SUBDIRS_TESTS = tests testsuite
+## FIXME: write tests from scratch
+SUBDIRS_TESTS =
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+else
+SUBDIRS_TESTS =
+SUBDIRS_CHECK =
+endif
 
-INCLUDES = $(GLIB_CFLAGS) $(GTK_CFLAGS) -I$(top_srcdir)
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
 
-EXTRA_DIST = README
+SUBDIRS = \
+       benchmarks      \
+       $(SUBDIRS_CHECK) \
+       misc            \
+       $(SUBDIRS_TESTS) \
+       $(SUBDIRS_EXAMPLES)
+
+# These are all the possible subdirs
+DIST_SUBDIRS = \
+       benchmarks \
+       check \
+       examples \
+       misc