]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - tests/Makefile.am
g_thread_create() is deprecated in GLib master, use g_thread_try_new() instead
[glsdk/gstreamer0-10.git] / tests / Makefile.am
index 14f67769c3ffc11a99094383ad4ed8083922a8ba..23ff192b73664da5639843777eef4e7f9899dd58 100644 (file)
@@ -1,11 +1,35 @@
-SUBDIRS = sched eos nego
+EXTRA_DIST = README
 
-noinst_PROGRAMS = init loadall simplefake states caps queue registry \
-paranoia rip mp3encode autoplug props case4 markup load tee autoplug2 autoplug3 \
-capsconnect padfactory autoplug4 incsched reaping threadlock mp1vid
+if BUILD_TESTS
+## SUBDIRS_TESTS = tests testsuite
+## FIXME: write tests from scratch
+SUBDIRS_TESTS =
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+else
+SUBDIRS_TESTS =
+SUBDIRS_CHECK =
+endif
 
-# we have nothing but apps here, we can do this safely
-LIBS += $(GST_LIBS)
-CFLAGS += $(GST_CFLAGS)
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
 
-EXTRA_DIST = README
+SUBDIRS = \
+       benchmarks      \
+       $(SUBDIRS_CHECK) \
+       misc            \
+       $(SUBDIRS_TESTS) \
+       $(SUBDIRS_EXAMPLES)
+
+# These are all the possible subdirs
+DIST_SUBDIRS = \
+       benchmarks \
+       check \
+       examples \
+       misc