]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - tests/Makefile.am
gststructure: early out when we know a value cannot be a subset
[glsdk/gstreamer0-10.git] / tests / Makefile.am
index 7693dd0f215577e326df7a1f082635c98f9c4e19..23ff192b73664da5639843777eef4e7f9899dd58 100644 (file)
@@ -1,18 +1,35 @@
-# This directory depends on an x86 computer, so if nasm is present, we're good
-# complain to hadess@hadess.net
-# bufspeed gives warnings, can someone please fix that ?
-if HAVE_NASM
-NASMDEP_DIR=memchunk #bufspeed
+EXTRA_DIST = README
+
+if BUILD_TESTS
+## SUBDIRS_TESTS = tests testsuite
+## FIXME: write tests from scratch
+SUBDIRS_TESTS =
+if HAVE_CHECK
+SUBDIRS_CHECK = check
 else
-NASMDEP_DIR=
+SUBDIRS_CHECK =
+endif
+else
+SUBDIRS_TESTS =
+SUBDIRS_CHECK =
 endif
 
-SUBDIRS = $(NASMDEP_DIR) muxing sched threadstate seeking
-
-noinst_PROGRAMS = lat
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
 
-lat_CFLAGS = $(GST_CFLAGS)
-lat_LDFLAGS = $(GST_LIBS)
+SUBDIRS = \
+       benchmarks      \
+       $(SUBDIRS_CHECK) \
+       misc            \
+       $(SUBDIRS_TESTS) \
+       $(SUBDIRS_EXAMPLES)
 
-EXTRA_DIST = README
-DIST_SUBDIRS= bufspeed memchunk muxing sched threadstate seeking
+# These are all the possible subdirs
+DIST_SUBDIRS = \
+       benchmarks \
+       check \
+       examples \
+       misc