]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - tests/Makefile.am
DEBIAN: Debianization
[glsdk/gstreamer0-10.git] / tests / Makefile.am
index 9eeeb6f2237158d990b8b7aa49e14a68137ee809..23ff192b73664da5639843777eef4e7f9899dd58 100644 (file)
@@ -1,19 +1,35 @@
-SUBDIRS = sched eos nego muxing
+EXTRA_DIST = README
 
-if GST_DISABLE_LOADSAVE
-GST_LOADSAVE_PROG =
+if BUILD_TESTS
+## SUBDIRS_TESTS = tests testsuite
+## FIXME: write tests from scratch
+SUBDIRS_TESTS =
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
 else
-GST_LOADSAVE_PROG = caps registry autoplug props tee autoplug2 capsconnect \
-                   padfactory autoplug4
+SUBDIRS_TESTS =
+SUBDIRS_CHECK =
 endif
 
-noinst_PROGRAMS = $(GST_LOADSAVE_PROG) init loadall simplefake states queue \
-paranoia rip mp3encode case4 markup load autoplug3 \
-incsched reaping threadlock mp1vid reconnect \
-faketest events timecache
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
 
-# we have nothing but apps here, we can do this safely
-LIBS = $(GST_LIBS)
-CFLAGS = $(GLIB_CFLAGS) $(XML_CFLAGS) $(GST_CFLAGS)
+SUBDIRS = \
+       benchmarks      \
+       $(SUBDIRS_CHECK) \
+       misc            \
+       $(SUBDIRS_TESTS) \
+       $(SUBDIRS_EXAMPLES)
 
-EXTRA_DIST = README
+# These are all the possible subdirs
+DIST_SUBDIRS = \
+       benchmarks \
+       check \
+       examples \
+       misc