]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/gstreamer0-10.git/blobdiff - tests/Makefile.am
DEBIAN: Debianization
[glsdk/gstreamer0-10.git] / tests / Makefile.am
index b9ee78f4a7d7192e187afe3ecc4dfd7c3bbd3b29..23ff192b73664da5639843777eef4e7f9899dd58 100644 (file)
@@ -1,12 +1,35 @@
+EXTRA_DIST = README
 
-SUBDIRS = instantiate memchunk muxing sched threadstate seeking # bufspeed
-
-if !GST_DISABLE_TRACE
-noinst_PROGRAMS = lat
+if BUILD_TESTS
+## SUBDIRS_TESTS = tests testsuite
+## FIXME: write tests from scratch
+SUBDIRS_TESTS =
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+else
+SUBDIRS_TESTS =
+SUBDIRS_CHECK =
+endif
 
-lat_CFLAGS = $(GST_OBJ_CFLAGS)
-lat_LDFLAGS = $(GST_OBJ_LIBS)
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
 endif
 
-EXTRA_DIST = README
-DIST_SUBDIRS= bufspeed instantiate memchunk muxing sched threadstate seeking
+SUBDIRS = \
+       benchmarks      \
+       $(SUBDIRS_CHECK) \
+       misc            \
+       $(SUBDIRS_TESTS) \
+       $(SUBDIRS_EXAMPLES)
+
+# These are all the possible subdirs
+DIST_SUBDIRS = \
+       benchmarks \
+       check \
+       examples \
+       misc