script: Add checks for unsupported Si revisions
authorNikhil Devshatwar <nikhil.nd@ti.com>
Mon, 29 Aug 2016 13:47:56 +0000 (19:17 +0530)
committerNikhil Devshatwar <nikhil.nd@ti.com>
Mon, 29 Aug 2016 13:47:56 +0000 (19:17 +0530)
Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com>
iodelay-autogen.py

index 41f9a3ad2d236204fa8ade4910152b33e3cf4fbd..677f68de8f72786ee24cec1761bc8ba80df94649 100755 (executable)
@@ -73,10 +73,15 @@ args.resetslew = True
 VERSION = "2.5"
 
 if (args.part == "dra74x" or args.part == "dra75x"):
+       if (args.revision == "1.0"):
+               args.revision = "1.1"
        XML_PATH = "XMLFiles/DRA75x_DRA74x"
        PART = "DRA75x_DRA74x"
        PCT_VERSION = "v1.0.10"
 elif (args.part == "dra72x"):
+       if (args.revision == "1.1"):
+               print "dra72x doesn't have silicon revision 1.1"
+               exit()
        XML_PATH = "XMLFiles/DRA72x"
        PART = "DRA72x"
        PCT_VERSION = "v1.0.7"