multi-kernel.inc: fix the unpack issue when there's no machine configs
[glsdk/meta-ti-glsdk.git] / README
1 This layer depends on:
3 URI: git://git.openembedded.org/openembedded-core
4 branch: master
5 revision: HEAD
7 URI: git://git.openembedded.org/meta-openembedded
8 branch: master
9 revision: HEAD
11 URI: git://git.angstrom-distribution.org/meta-angstrom
12 branch: master
13 revision: HEAD
15 Currently meta-ti only works with the Angstrom distribution and hence
16 requires the meta-angstrom layer. There are known issues when using
17 gcc-4.6 based toolchain from OpenEmbedded-Core, thus gcc-4.5 toolchain,
18 provided by meta-openembedded, is needed. It is planned to fix these
19 shortcomings in the near future and allow building the base BSP part
20 of meta-ti with different distributions and layer stacks, such as:
21 distro-less (only with OE-Core), with Yocto/Poky, with Angstrom or
22 Arago.
24 Due to the above, it is now recommended to follow the instructions at
25 http://www.angstrom-distribution.org/building-angstrom
27 This will set it up for the OpenEmbedded-core layout instead of the
28 old "Classic" OpenEmbedded-dev layout. You can optionally tweak
29 sources/layers.txt and conf/bblayers.conf to (de)select BSP layers.
31 Send pull requests to meta-ti@yoctoproject.org
33 Main layer maintainers: Denys Dmytriyenko <denys@ti.com>
34                         Koen Kooi <k-kooi@ti.com>