]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-bsp/u-boot/u-boot_2011.09.bb
u-boot 2011.12: switch beagleboard to ext4 to match beaglebone
[glsdk/meta-ti-glsdk.git] / recipes-bsp / u-boot / u-boot_2011.09.bb
1 require u-boot.inc
3 PR = "r7"
5 # SPL build
6 UBOOT_BINARY = "u-boot.img"
7 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
8 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
10 # No patches for other machines yet
11 COMPATIBLE_MACHINE = "(beagleboard)"
13 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
14            file://2011.09/0001-omap3-mem-Comment-enable_gpmc_cs_config-more.patch \
15            file://2011.09/0002-OMAP3-Update-SDRC-dram_init-to-always-call-make_cs1_.patch \
16            file://2011.09/0003-OMAP3-Add-a-helper-function-to-set-timings-in-SDRC.patch \
17            file://2011.09/0004-OMAP3-Change-mem_ok-to-clear-again-after-reading-bac.patch \
18            file://2011.09/0005-OMAP3-Remove-get_mem_type-prototype.patch \
19            file://2011.09/0006-omap3-mem-Add-MCFG-helper-macro.patch \
20            file://2011.09/0007-OMAP3-Add-optimal-SDRC-autorefresh-control-values.patch \
21            file://2011.09/0008-OMAP3-Suffix-all-Micron-memory-timing-parts-with-the.patch \
22            file://2011.09/0009-OMAP3-SPL-Rework-memory-initalization-and-devkit8000.patch \
23            file://2011.09/0010-OMAP3-SPL-Add-identify_nand_chip-function.patch \
24            file://2011.09/0011-OMAP3-Add-SPL-support-to-Beagleboard.patch \
25            file://2011.09/0012-OMAP3-Add-SPL-support-to-omap3_evm.patch \
26            file://2011.09/0013-AM3517-Add-SPL-support.patch \
27            file://2011.09/0014-AM3517-CraneBoard-Add-SPL-support.patch \
28            file://2011.09/0015-HACK-beagleboard-config-disable-cache-for-USB.patch \
29            file://2011.09/0016-beagleboard-config-enable-gpio-command.patch \
30            file://2011.09/0017-Increased-some-timeout-durations-for-MMC-and-EHCI.patch \
31            file://2011.09/0018-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch \
32            file://2011.09/0019-BeagleBoard-config-Really-switch-to-ttyO2.patch \
33            file://2011.09/0020-beagleboard-add-support-for-TCT-Beacon-board.patch \
34            file://2011.09/0021-beagleboard-add-support-for-scanning-loop-through-ex.patch \
35            file://0001-config-Always-use-GNU-ld.patch \
36            file://fw_env.config \
37           "
39 SRCREV = "fdbe8b9a2d1858ba35dd6214315563ad44d4a0e3"
41 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
43 S = "${WORKDIR}/git"