]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-bsp/u-boot/u-boot_2011.10rc.bb
314446a4e0e2effa4cdbd84985f164f48cc8c8cf
[glsdk/meta-ti-glsdk.git] / recipes-bsp / u-boot / u-boot_2011.10rc.bb
1 require u-boot.inc
3 # No patches for other machines yet
4 COMPATIBLE_MACHINE = "beaglebone"
5 DEFAULT_PREFERENCE_beaglebone = "99"
6 PV = "2011.09+git"
7 PR = "r7"
9 # SPL build
10 UBOOT_BINARY = "u-boot.img"
11 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
12 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
14 SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
15            file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \
16            file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \
17            file://2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch \
18           "
20 SRCREV = "456880b203bc44c025c374c98fa327b804a9cf64"
22 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
24 S = "${WORKDIR}/git"
26 do_deploy_append () {
27     install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO
28 }