48bc618a68d2efffdb0472ded5b9cf2be5ebd850
1 require u-boot.inc
3 # No patches for other machines yet
4 COMPATIBLE_MACHINE = "(ti33x)"
6 DEFAULT_PREFERENCE_ti33x = "99"
8 PV = "2011.09+git"
9 PR = "r27"
11 # SPL build
12 UBOOT_BINARY = "u-boot.img"
13 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
14 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
16 SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
17 file://2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch \
18 file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \
19 file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \
20 file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \
21 file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
22 file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
23 file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
24 file://2011.09git/0008-HACK-am335x-evm-turn-d-cache-on-globally-turn-it-off.patch \
25 file://2011.09git/0009-am335x-evm-enable-i2c2-pinmux-for-beaglebone.patch \
26 file://2011.09git/0001-ddr_defs-change-DDR-timings-for-15x15-EVM.patch \
27 file://2011.09git/0011-ext2load-increase-read-speed.patch \
28 file://2011.09git/0012-am335x-evm-fix-ext2load-and-specify-partition-for-bo.patch \
29 file://2011.09git/0013-am335x-evm-load-uImage-from-boot-instead-of-VFAT.patch \
30 file://2011.09git/0014-ext4fs-ls-load-support.patch \
31 file://2011.09git/0015-am335x-switch-to-ext4-mode.patch \
32 "
34 SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"
36 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
38 S = "${WORKDIR}/git"