ad6d74ce6d1fd97d165f21f3dc8536369da9029f
1 require u-boot.inc
3 # No patches for other machines yet
4 COMPATIBLE_MACHINE = "beaglebone"
5 DEFAULT_PREFERENCE_beaglebone = "99"
6 PV = "2011.09+git"
7 PR = "r8"
9 # SPL build
10 UBOOT_BINARY = "u-boot.img"
11 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
12 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
14 SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
15 file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \
16 file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \
17 file://2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch \
18 "
20 SRCREV = "3fb65523c5994718b56a3b4b18ddf1ef3ffc02dc"
22 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
24 S = "${WORKDIR}/git"
26 do_deploy_append () {
27 install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO
28 }