]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-bsp/u-boot/u-boot_2011.10rc.bb
u-boot 2011.10rc: move beaglebone to ext4
[glsdk/meta-ti-glsdk.git] / recipes-bsp / u-boot / u-boot_2011.10rc.bb
1 require u-boot.inc
3 # No patches for other machines yet
4 COMPATIBLE_MACHINE = "(ti33x)"
5 DEFAULT_PREFERENCE_ti33x = "99"
6 PV = "2011.09+git"
7 PR = "r20"
9 # SPL build
10 UBOOT_BINARY = "u-boot.img"
11 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
12 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
14 SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
15            file://2011.09git/0001-am335x_evm-only-do-in-kernel-dhcp-when-using-NFS-use.patch \
16            file://2011.09git/0002-am335x_evm-boot-kernel-from-boot-in-ext2-3-filesyste.patch \
17            file://2011.09git/0003-am335x_evm-set-bootdelay-to-1.patch \
18            file://2011.09git/0004-am335x-evm-make-MMC-rootfs-RO-on-boot-so-fsck-works.patch \
19            file://2011.09git/0005-am335x-Change-mmc_load_uimage-to-load-at-a-fixed-add.patch \
20            file://2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch \
21            file://2011.09git/0007-am335x_evm-switch-to-ext4.patch \
22           "
24 SRCREV = "f63b270e47f62f4d1a05b2001357e215966c6f5a"
26 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
28 S = "${WORKDIR}/git"
30 do_deploy_append () {
31     install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO
32 }