]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-bsp/u-boot/u-boot_2011.12.bb
am37x-evm.conf: Use '+=' not '?=' in IMAGE_FSTYPES
[glsdk/meta-ti-glsdk.git] / recipes-bsp / u-boot / u-boot_2011.12.bb
1 require u-boot.inc
3 # SPL build
4 UBOOT_BINARY = "u-boot.img"
5 UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6 UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
8 PV = "2011.12"
9 PR = "r6"
11 # No patches for other machines yet
12 COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"
14 # Non-omap4 platforms need outer cache turned on
15 CACHEFIX = "file://2011.12/0008-Revert-armv7-disable-L2-cache-in-cleanup_before_linu.patch"
16 CACHEFIX_omap4 = ""
18 # File is board-specific, only copy when it will be correct.
19 FWENV_beagleboard = "file://fw_env.config"
20 FWENV = ""
22 SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
23            file://2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch \
24            file://2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch \
25            file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \
26            file://2011.12/0004-omap4-common-mount-root-RO.patch \
27            file://2011.12/0005-omap4-common-use-ext4-by-default.patch \
28            file://2011.12/0006-OMAP-MMC-Add-delay-before-waiting-for-status.patch \
29            file://2011.12/0007-config-Always-use-GNU-ld.patch \
30            ${CACHEFIX} \
31            file://2011.12/0009-Beagleboard-Correct-memory-size-on-rev-C4.patch \
32            file://2011.12/0010-OMAP3-Correct-get_sdr_cs_offset-mask.patch \
33            ${FWENV} \
34           "
37 # v2011.12 tag
38 SRCREV = "cba9a894fdb1cb49b60fcd1d1d6919cbd7995dd5"
40 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
42 S = "${WORKDIR}/git"
44 RRECOMMENDS_${PN}_beagleboard = "u-boot-fw-utils"