1 # Use the version of u-boot.inc in oe-core not the meta-ti version
2 require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
4 DESCRIPTION = "u-boot bootloader for ARM MPU devices"
6 LICENSE = "GPLv2+"
7 LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
9 DEFAULT_PREFERENCE = "-1"
11 COMPATIBLE_MACHINE = "am37x-evm|beagleboard"
13 PACKAGE_ARCH = "${MACHINE_ARCH}"
15 BRANCH ?= "master"
17 SRCREV = "v2012.04.01"
19 S = "${WORKDIR}/git"
21 SRC_URI = "git://git.denx.de/u-boot.git;protocol=git;branch=${BRANCH}"
23 # Add patches for the AMSDK
24 # - 0001-omap3-beagle-add-usbethaddr....Not for Upstream
25 # - 0001-OMAP3-Beagle-Set-BOOTDELAY....Pending Upstream
26 # - 0002-am335x-am3517evm-beagleboard....Pending Upstream
27 # - 0003-beagleboard-Load-uImage-from....Not for Upstream
28 # - 0004-beagleboard-Load-uImage-to....Pending Upstream
29 # - 0001-omap3_evm-Added-function....Pending Upstream
30 # - 0002-omap3evm-Make-the-board....Pending Upstream
31 # - 0003-beagleboard-Make-xM-rev....Pending Upstream
32 # - 0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch....Upstreamed
34 # Add a patch to set a default usbethaddr address to enable the out of box
35 # experience.
36 SRC_URI += "file://0001-omap3_beagle-add-usbethaddr-setting-to-enable-networ.patch \
37 file://0001-OMAP3-Beagle-Set-BOOTDELAY-to-3.patch \
38 file://0002-am335x-am3517evm-beagleboard-am37x-Add-CONFIG_CMD_AS.patch \
39 file://0003-beagleboard-Load-uImage-from-VFAT-by-default.patch \
40 file://0004-beagleboard-Load-uImage-to-the-default-kernel-linux-.patch \
41 file://0001-omap3_evm-Added-function-calls-to-set-volts-speed-on.patch \
42 file://0002-omap3evm-Make-the-board-start-at-800MHz.patch \
43 file://0003-beagleboard-Make-xM-rev-C-go-to-800MHz.patch \
44 file://0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch \
45 "
47 UBOOT_SUFFIX = "img"
49 # Set the name of the SPL that will built so that it is also packaged with u-boot.
50 SPL_BINARY = "MLO"