1 BINLOCATION_omap3 = "${S}/gfx_rel_es3.x"
2 BINLOCATION_ti816x = "${S}/gfx_rel_es6.x"
4 ES2LOCATION = "${S}/gfx_rel_es2.x"
5 ES3LOCATION = "${S}/gfx_rel_es3.x"
6 ES5LOCATION = "${S}/gfx_rel_es5.x"
7 ES6LOCATION = "${S}/gfx_rel_es6.x"
9 require libgles-omap3.inc
11 # download required binary distribution from:
12 # http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/latest/index_FDS.html
13 # see libgles-omap3.inc for detailed installation instructions
15 SGXPV = "4_03_00_02"
16 IMGPV = "1.6.16.3977"
17 BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin"
19 SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \
20 file://cputype \
21 file://rc.pvr \
22 file://sample.desktop \
23 file://99-bufferclass.rules \
24 "
26 SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada"
27 SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255"
29 S = "${WORKDIR}"