]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-kernel/linux/linux-am335x_3.2.0-psp04.06.00.08.bb
linux: Use setup-defconfig in kernel recipes
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-am335x_3.2.0-psp04.06.00.08.bb
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for TI33x devices from PSP"
3 LICENSE = "GPLv2"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
5 COMPATIBLE_MACHINE = "ti33x"
7 DEFAULT_PREFERENCE = "-1"
9 inherit kernel
10 require setup-defconfig.inc
12 # Stage the power management firmware before building the kernel
13 DEPENDS += "am33x-cm3"
15 KERNEL_IMAGETYPE = "uImage"
17 # The main PR is now using MACHINE_KERNEL_PR, for ti33x see conf/machine/include/ti33x.inc
18 MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}"
20 BRANCH = "v3.2-staging"
22 # This SRCREV corresponds to tag v3.2_AM335xPSP_04.06.00.08
23 SRCREV = "d7e124e8074cccf9958290e773c88a4b2b36412b"
25 SRC_URI = "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;branch=${BRANCH} \
26            file://defconfig \
27            ${KERNEL_PATCHES} \
28 "
30 S = "${WORKDIR}/git"
32 # Allow a layer to easily add to the list of patches or completely override them.
33 KERNEL_PATCHES ?= "${PATCHES}"
35 # Add a set of patches that enabled features, fixed bugs or disabled buggy features
36 # that weren't part of the official PSP release
37 PATCHES = "file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch \
38                file://0001-am335x_evm_defconfig-turn-off-MUSB-DMA.patch \
39                file://0001-mach-omap2-pm33xx-Disable-VT-switch.patch"
41 # Add Cryptography support early driver patches while working to get the driver
42 # upstream.
43 PATCHES += "file://0001-am33x-Add-memory-addresses-for-crypto-modules.patch \
44                 file://0002-am33x-Add-crypto-device-and-resource-structures.patch \
45                 file://0003-am33x-Add-crypto-device-and-resource-structure-for-T.patch \
46                 file://0004-am33x-Add-crypto-drivers-to-Kconfig-and-Makefiles.patch \
47                 file://0005-am33x-Create-header-file-for-OMAP4-crypto-modules.patch \
48                 file://0006-am33x-Create-driver-for-TRNG-crypto-module.patch \
49                 file://0007-am33x-Create-driver-for-AES-crypto-module.patch \
50                 file://0008-am33x-Create-driver-for-SHA-MD5-crypto-module.patch \
51                 file://0002-AM335x-OCF-Driver-for-Linux-3.patch \
52                 file://0001-am335x-Add-crypto-driver-settings-to-defconfig.patch \
53                 file://0001-am335x-Add-pm_runtime-API-to-crypto-driver.patch \
54                 file://0002-am335x-Add-suspend-resume-routines-to-crypto-driver.patch \
55                "
57 # Add SmartReflex support early driver patches while working to get the driver
58 # upstream.
59 PATCHES += "file://0001-am33xx-Add-SmartReflex-support.patch \
60                 file://0002-am33xx-Enable-CONFIG_AM33XX_SMARTREFLEX.patch \
61                "
63 # Add a patch to the omap-serial driver to allow suspend/resume during
64 # Bluetooth traffic
65 PATCHES += "file://0001-omap-serial-add-delay-before-suspending.patch"
67 # Add patch to allow wireless to work properly on EVM-SK 1.2.
68 PATCHES += "file://0001-am3358-sk-modified-WLAN-enable-and-irq-to-match-boar.patch"
70 # Add CPU utilization patch for WLAN
71 PATCHES += "file://0001-am335xevm-using-edge-triggered-interrupts-for-WLAN.patch"
73 # Add patch to enable pullup on WLAN enable
74 PATCHES += "file://0001-am335x-enable-pullup-on-the-WLAN-enable-pin-fo.patch"
76 # Copy the am33x-cm3 firmware if it is available
77 do_compile_prepend() {
78     if [ -e "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" ]
79     then
80         cp "${STAGING_DIR_HOST}/${base_libdir}/firmware/am335x-pm-firmware.bin" "${S}/firmware"
81     fi
82 }