]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-kernel/linux/linux-davinci_git.bb
omap3-touchbook: remove machine definition, since it's unsupported
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-davinci_git.bb
1 require multi-kernel.inc
3 DESCRIPTION = "Linux kernel for DaVinci processors"
4 KERNEL_IMAGETYPE = "uImage"
6 COMPATIBLE_MACHINE = "hawkboard"
8 DEFAULT_PREFERENCE_hawkboard = "1"
10 BRANCH = "master"
12 SRC_URI_append = " file://defconfig "
14 S = "${WORKDIR}/git"
16 # The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
18 # OMAPL tracking master branch - PSP 3.20.00.12
20 ARAGO_L1_REV = "2acf935c01b9adb50164d421c40cdc5862b9e143"
21 ARAGO_L1_BR  = "master"
22 ARAGO_L1_PV  = "2.6.32+2.6.33-rc4-${PR}+gitr${SRCREV}"
23 ARAGO_L1_URI = "git://arago-project.org/git/projects/linux-omapl1.git;protocol=git;branch=${BRANCH} "
25 SRCREV_hawkboard                  = "${ARAGO_L1_REV}"
27 PV_omapl138             = "${ARAGO_L1_PV}"
29 BRANCH_omapl138         = "${ARAGO_L1_BR}"
31 SRC_URI_append_omapl138 = "${ARAGO_L1_URI}"
33 SRC_URI_append_omapl138 = " file://logo_linux_clut224.ppm \
34                                      file://0001-ahci-ti-Fix-currently-harmless-typo-in-SATA-PHY.patch \
35                                      file://0002-ahci-ti-Update-SATA-PHY-configuration-RXCDR.patch \
36                                      file://0001-board-da850-evm-Disable-NAND-SUBPAGE.patch \
37                                      file://0001-uio_pruss1-Core-driver-addition.patch \
38                                      file://0002-uio_pruss2-Platform-changes.patch \
39                                      file://0003-uio_pruss3-Workarounds-put-into-core-code.patch \
40                                      file://0001-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch \
41                                      file://0001-ARM-6329-1-wire-up-sys_accept4-on-ARM.patch \
42                                     "
44 SRC_URI_append_hawkboard          = " \
45                                      file://patch-2.6.33rc4-psp-to-hawkboard.patch \
46                                      file://0001-board-da850-hawk-Disable-NAND-SUBPAGE.patch \
47                                     "
49 # Perf in 2.6.33rc has broken perl handling, so disable it
50 do_compile_perf() {
51     :
52 }
54 do_install_perf() {
55     :
56 }