]> Gitweb @ Texas Instruments - Open Source Git Repositories - git.TI.com/gitweb - glsdk/meta-ti-glsdk.git/blob - recipes-kernel/linux/linux-omap-psp_2.6.37.bb
multi-kernel.inc: drop use of KERNEL_CCSUFFIX to match oe-core
[glsdk/meta-ti-glsdk.git] / recipes-kernel / linux / linux-omap-psp_2.6.37.bb
1 require linux.inc
3 DESCRIPTION = "Linux kernel for OMAP3 EVM from PSP, based on linux-omap3 kernel"
5 COMPATIBLE_MACHINE = "omap3"
7 SRCREV= "20c003f2f024d9f50f59edf9f1b8f5f035fb15b8"
9 SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \
10            file://defconfig"
12 # The following patches below have been upstreamed to linux kernel 2.6.39 tree
13 # and will not be needed once we move to this kernel.
14 # The only exception is "0002-allow-selecting-WL12XX_PLATFROM_DATA-independently.patch"
15 # which is needed for building against a compat-wireless package
16 SRC_URI += " \
17     file://0001-linux-omap3-Add-OCF-support-to-2.6.37-kernel.patch \
18     file://0001-omap3evm-add-support-for-the-WL12xx-WLAN-module.patch \
19     file://0002-allow-selecting-WL12XX_PLATFROM_DATA-independently.patch \
20     file://0003-mmc-skip-detection-of-nonremovable-cards-on-rescan.patch \
21     file://0004-mmc-sdio-don-t-reinitialize-nonremovable-powered-res.patch \
22     file://0005-mmc-sdio-don-t-power-up-cards-on-system-suspend.patch \
23     file://0006-wl12xx-Backport-wl12xx-platform-data.patch \
24     file://0007-activate-wireless-extensions.patch \
25 "
27 # Update the kernel to support suspend/resume when the file system is located
28 # on the SD card.  This is also being submitted to the PSP team for inclusion
29 # in future releases.
30 SRC_URI += " \
31     file://0001-Fix-matrix-suspend.patch \
32 "
34 # Update the OCF kernel patch to remove non-existing components for
35 # non-TI hardware.  This allows the make clean target to work.
36 # Update the defconfig for omap3 to enable OCF and WLAN by default
37 SRC_URI += " \
38     file://0001-OCF-support-remove-support-for-non-TI-hardware.patch \
39     file://0002-omap3_evm_defconfig-add-OCF-driver-support.patch \
40     file://0003-omap3_evm_defconfig-add-WLAN-config-options.patch \
41 "
43 # Enable clock pad register in mt9t111 sensor driver. This fixes the issue where
44 # sensor sync pulses were not generated during first loopback after boot-up.
45 SRC_URI += " \
46     file://0001-mt9t111-enable-clock-pad-register-in-configuration.patch \
47 "
49 # The following patches add support for wake on wlan (WoWlan)
50 # which is supported in nlcp R4 release
51 SRC_URI += "file://0001-omap3evm-add-wake-on-wlan-support.patch \
52     file://0001-nlcp-sdio-fixes-for-wowlan-support.patch \
53     file://0002-mmc-sdio-support-suspend-resume-while-runtime-suspen.patch \
54     file://0003-mmc_card_keep_power-cleanups.patch \
55     file://0004-mmc-do-not-switch-to-1-bit-mode-if-not-required.patch \
56     file://0005-mmc-fix-division-by-zero-in-MMC-core.patch \
57     file://0006-revert-duplicate-insertion-of-mmc_card_keep_power-fu.patch \
58 "
60 # The following patches allow for NOR to be enabled and built
61 # easily.
62 SRC_URI += " \
63     file://0001-omap3-am3517evm-Allow-for-NAND-to-really-be-disabled.patch \
64     file://0002-omap3-am3517evm-Update-NOR-partition-table.patch \
65     file://0003-AM3517-Add-am3517_evn_nor_defconfig.patch \
66 "
68 # The following patch sets the dto timeout for SD cards to the max of 14.
69 # This has been found to make SD cards work more reliably in the omap3 systems
70 SRC_URI += " \
71     file://0001-omap_hsmmc-make-default-dto-value-14.patch \
72 "
74 # Add ABB support to the Linux kernel to enable 1GHz OPP and to allow
75 # booting at 1GHz
76 SRC_URI += " \
77     file://0001-am37x-Adding-ABB-Support-for-1GHz-OPP.patch \
78 "
80 # Fix USB role switching when leaving USB cable connected
81 SRC_URI += " \
82     file://0001-usb-musb-am35x-set-default-VBUS-timeout-value.patch \
83     file://0002-usb-musb-am35x-fix-role-switching-issue.patch \
84 "
86 # Updated PIO mode for MUSB help description
87 SRC_URI_append_am3517-evm = " file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch"
89 S = "${WORKDIR}/git"