1 require linux.inc
2 require setup-defconfig.inc
4 DESCRIPTION = "Linux kernel for OMAP3 EVM from PSP, based on linux-omap3 kernel"
6 COMPATIBLE_MACHINE = "omap3"
8 # SRCREV corresponds to tag v2.6.37_OMAPPSP_04.02.00.07
9 SRCREV= "adcd067326836777c049e3cb32a5b7d9d401fc31"
11 # The main PR is now using MACHINE_KERNEL_PR, for omap3 devices
12 # see conf/machine/include/omap3.inc
13 MACHINE_KERNEL_PR_append = "b"
15 SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=git \
16 file://defconfig"
18 # The following patches below have been upstreamed to linux kernel 2.6.39 tree
19 # and will not be needed once we move to this kernel.
20 # The only exception is "0002-allow-selecting-WL12XX_PLATFROM_DATA-independently.patch"
21 # which is needed for building against a compat-wireless package
22 SRC_URI += " \
23 file://0001-linux-omap3-Add-OCF-support-to-2.6.37-kernel.patch \
24 file://0001-omap3evm-add-support-for-the-WL12xx-WLAN-module.patch \
25 file://0002-allow-selecting-WL12XX_PLATFROM_DATA-independently.patch \
26 file://0003-mmc-skip-detection-of-nonremovable-cards-on-rescan.patch \
27 file://0004-mmc-sdio-don-t-reinitialize-nonremovable-powered-res.patch \
28 file://0005-mmc-sdio-don-t-power-up-cards-on-system-suspend.patch \
29 file://0006-wl12xx-Backport-wl12xx-platform-data.patch \
30 file://0007-activate-wireless-extensions.patch \
31 "
33 # Update the kernel to support suspend/resume when the file system is located
34 # on the SD card. This is also being submitted to the PSP team for inclusion
35 # in future releases.
36 SRC_URI += " \
37 file://0001-Fix-matrix-suspend.patch \
38 "
40 # Update the OCF kernel patch to remove non-existing components for
41 # non-TI hardware. This allows the make clean target to work.
42 # Update the defconfig for omap3 to enable OCF and WLAN by default
43 SRC_URI += " \
44 file://0001-OCF-support-remove-support-for-non-TI-hardware.patch \
45 file://0002-omap3_evm_defconfig-add-OCF-driver-support.patch \
46 file://0003-omap3_evm_defconfig-add-WLAN-config-options.patch \
47 "
49 # Enable clock pad register in mt9t111 sensor driver. This fixes the issue where
50 # sensor sync pulses were not generated during first loopback after boot-up.
51 SRC_URI += " \
52 file://0001-mt9t111-enable-clock-pad-register-in-configuration.patch \
53 "
55 # The following patches add support for wake on wlan (WoWlan)
56 # which is supported in nlcp R4 release
57 SRC_URI += "file://0001-omap3evm-add-wake-on-wlan-support.patch \
58 file://0001-nlcp-sdio-fixes-for-wowlan-support.patch \
59 file://0002-mmc-sdio-support-suspend-resume-while-runtime-suspen.patch \
60 file://0003-mmc_card_keep_power-cleanups.patch \
61 file://0004-mmc-do-not-switch-to-1-bit-mode-if-not-required.patch \
62 file://0005-mmc-fix-division-by-zero-in-MMC-core.patch \
63 file://0006-revert-duplicate-insertion-of-mmc_card_keep_power-fu.patch \
64 "
66 # The following patches allow for NOR to be enabled and built
67 # easily.
68 SRC_URI += " \
69 file://0001-omap3-am3517evm-Allow-for-NAND-to-really-be-disabled.patch \
70 file://0002-omap3-am3517evm-Update-NOR-partition-table.patch \
71 file://0003-AM3517-Add-am3517_evn_nor_defconfig.patch \
72 "
74 # The following patch sets the dto timeout for SD cards to the max of 14.
75 # This has been found to make SD cards work more reliably in the omap3 systems
76 SRC_URI += " \
77 file://0001-omap_hsmmc-make-default-dto-value-14.patch \
78 "
80 # Add ABB support to the Linux kernel to enable 1GHz OPP and to allow
81 # booting at 1GHz
82 SRC_URI += " \
83 file://0001-am37x-Adding-ABB-Support-for-1GHz-OPP.patch \
84 "
86 # Fix USB role switching when leaving USB cable connected
87 SRC_URI += " \
88 file://0001-usb-musb-am35x-set-default-VBUS-timeout-value.patch \
89 file://0002-usb-musb-am35x-fix-role-switching-issue.patch \
90 "
92 # Fix alignment issue with gcc-4.7
93 SRC_URI += " \
94 file://0001-arm-fix-builds-with-gcc-4.7.patch \
95 "
97 # Updated PIO mode for MUSB help description
98 SRC_URI_append_am3517-evm = " file://0001-musb-update-PIO-mode-help-information-in-Kconfig.patch"
100 S = "${WORKDIR}/git"